1

I am playing Silent Hill 2 from the Silent Hill HD Collection available for the X360. Simply put, I can't find a way to save or to quit to the main menu.

Now I have played similar type of games before and some of them have fixed save points (like Deadspace). I am wondering if this one does as well. So far I haven't been able to find them.

There is also the question of quitting the game. How do I do that? I can't find it anywhere in the Start button menu.

Since I can't save, I've had to leave my Xbox on all day!

If this is classified as two questions, I am most happy to split this into two separate question threads.

2
  • Really no one knows? Aug 8, 2012 at 20:49
  • It usually takes a few hours at least to get an answer to a game that isn't Skyrim or Diablo or Portal around here, but answers usually do come.
    – GnomeSlice
    Aug 9, 2012 at 18:40

1 Answer 1

2

Save points in Silent Hill 2 look like red pieces of paper - http://uk.faqs.ign.com/articles/121/1215833p1.html - heres a list of where they all are.

Straight from IGN: "You may notice that there is no "Quit" option while playing Silent Hill. Maybe you want to go back to a previous save, or maybe you want to play a different file. There's no "Load" option either! Press and Hold the four shoulder buttons, START, and BACK simultaneously to return to the main menu of Silent Hill 2 or Silent Hill 3.

However, if you want to go back to the Silent Hill HD Collection menu to choose a different game or different set of voices, you'll have to completely quit out of the game and restart it."

First result on google, c'mon man. Try harder.

3
  • Thanks for the answer. Just for your info, I found the answer right after posting this. I just wanted to see if anyone would post an answer. By the way I have tried this method to quit, but it hasn't worked for me (by the four shoulder buttons, I assume it's LB RB LT RT.) I will try again tonight, maybe I didn't do it right. Aug 10, 2012 at 0:24
  • Let me know how it goes/if you find a way to quit!!
    – twgoff
    Aug 10, 2012 at 13:36
  • 1
    I got it. I misunderstood IGN's instructions. I thought they meant - hold down the four shoulder buttons, hit start then hit back. No no. It's 'hold down all six of the buttons.' at the same time. I edited your answer slightly. Hope that's ok. Aug 11, 2012 at 0:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .