The kids have got into Minecraft and want to run their own multiplayer game locally, however, we can't get one computer to connect to the other, but the reverse connection works.

COMPUTER A is the better machine and we want to run the server on that as well as a client. COMPUTER B can only really run either the server or the client. It's good enough to run TF2 etc. so it's not underpowered.

What works:

Run the server on COMPUTER B. We can run the client on COMPUTER A and connect to the server without any problems. We can also run the client on COMPUTER B and connect to the server, but it's unplayable.

What doesn't work:

Run the server on COMPUTER A. Running the client on COMPUTER A works and gives a decent frame rate etc. However, from COMPUTER B when we try to connect it appears to work, but then 30 seconds later it times out. The server reports that the connection has been made and then lost.

We have Sygate personal firewall on COMPUTER A which has a 1GB network card. This computer is also running IPv6.

We have Comodo firewall pro on COMPUTER B which has a 100MB network card. This computer is still running IPv4.

The two are connected via a 1GB switch.

Both firewalls have rules set up to allow all local traffic of any protocol on any port through. We haven't tried turning the firewalls off (that's for this afternoon), but I thought I'd see if there was anything else I could try.


The messages in the server are:

[INFO] User [/] logged in

then 30 seconds or so later:

[INFO] User lost connection: End of stream

We've just tried with firewalls on both computers disabled and got the following:

[INFO] Disconnecting / Took too long to log in

Still at complete loss, but it does appear to indicate that it's a network connectivity issue.


I should have added that we're running XP SP3 on both machines. COMPUTER A is new hardware and (obviously) a new installation of all drivers and software. COMPUTER B is old hardware (hence the problem) but has recently been reformatted/reinstalled.


Just tried again with server version 0.2.4 and the latest client and we get the following message on the server log:

[WARNING] Can't keep up! Did the system time change, or is the server overloaded?

This is with nothing else running on this machine and no one connected. I would have thought an Intel Core 2 Duo E7500 @ 2.93GHz with 2 Gb of RAM and Physical Address Extension should be able to run the server software OK.

  • 1
    I'd use Wireshark on both ends to make further investigation, since I don't have any clue about why there is so much asymmetry between the two ends.
    – badp
    Commented Sep 26, 2010 at 16:15
  • @badp - tried that, but not sure what it's telling me ;) Getting some [TCP retransmission] statements, but no idea what that means.
    – ChrisF
    Commented Sep 26, 2010 at 17:08
  • If I'm not completely out of it, a TCP retransmission happens due to packet loss. You might just be onto something...
    – badp
    Commented Sep 26, 2010 at 17:43
  • 1
    Yeah, it sounds like a bad connection/cable somewhere or a bad switch. I'd start with your basic ICMP tools: ping and tracert between the computers. See if one is accidentally routing to a non-local switch. I've had many weirdly long local pings turn out to be slightly broken LAN cables, myself. Also, if your switch is using IPv6, maybe there is some 6-to-4 issue with it and you could try using IPv6 on both machines. Although that seems unlikely to me.
    – WorldMaker
    Commented Sep 27, 2010 at 9:37
  • @WorldMaker - interesting. I'll check the cables for damage.
    – ChrisF
    Commented Sep 27, 2010 at 10:11

5 Answers 5


On Service Pack 3, there seems to be a lot of problems you apparently can't get around.

Quoting this topic: http://www.minecraftforum.net/viewtopic.php?f=1013&t=22790#p412298

[INFO] Player1 lost connection: End of stream
  You're running Windows XP Service Pack 3.
  Run Minecraft on a Virtual Machine on your computer,
  or use one with a different OS. Sorry!
  • Interesting, but I would have expected to get the same error on both machines and a client on COMPUTER A can connect to the server on COMPUTER A quite happily.
    – ChrisF
    Commented Sep 28, 2010 at 14:25

Yo, I was having the same problem. I found a way. The problem was caused by Atheros L1 network adapter "number of receive buffers" count. The default is 256; after I increased it to 1024, the problem disappeared. This picture shows you how.


Update your network adapter driver on the host computer. Worked for me. I'm going to have a stab and also say that you are using XP SP3 on the host computer. Common problem, apparently...

  • XP SP3 on both machines. COMPUTER A is new hardware. COMPUTER B is old hardware but has recently been reformatted/reinstalled.
    – ChrisF
    Commented Sep 28, 2010 at 10:51

A quick guess on this is the fact that you may be using your static ip address on client 2. If client 1 and client 2 are on a router, find the Dynamic IP of the computer that hosts the server. and try connecting with that. Also port forward if you haven't.

  • 7
    You don't have to port forward if you are connecting locally... Commented Sep 11, 2011 at 12:23
  • It is still a good idea for using
    – Timtech
    Commented Sep 21, 2013 at 18:24

Check the IP addresses of the two computers. If they both have the same IP address, then that is the cause of the problem.

You can check IP addresses like this:

  • Press Windows-Key + R
  • Type CMD
  • Type ipconfig into command prompt
  • Hit enter
  • Scroll down to where it says: Ipv4 Address
  • Your ip address is listed there!

I hope this helps!

  • This usually never happens; although they may have changed and as a result you can't access it.
    – Timtech
    Commented Sep 21, 2013 at 18:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .