I'm getting a black screen when I try to open a StarCraft 2 replay (which is probably from an older SC2 version than the current one). What can I do to be able to watch the replay?


  • I do get the SC2 cursor for the mouse in that black screen.
  • I've tried other replays from that same version and they behave the same (black screen).
  • I've tried a replay from the latest version and it works fine.
  • My drivers are up to date.
  • My SC2 version is 1.1.1.
  • 2
    I had this problem as well, I just had to update my video card drivers and it started working. what version of sc2 is the replay? I think I read something somewhere that if its before a certain beta patch you cant watch it anymore.
    – Latency
    Sep 28, 2010 at 17:23
  • Are you trying to launch it via your OS or via StarCraft itself? I ask because I double clicked an old replay in Windows and it crashed, but opening in SC worked fine.
    – Mag Roader
    Nov 14, 2010 at 1:18
  • Have you tried running C:\Program Files (x86)\StarCraft II\Support\Repair.exe? Dec 14, 2010 at 2:09
  • Are you still having this problem Oak?
    – juan
    Dec 14, 2010 at 3:08
  • @Juan unfortunately, yes :(
    – Oak
    Dec 14, 2010 at 6:28

4 Answers 4


Problem #17: Encounter Black Screen when trying to run Starcraft 2: Wings of Liberty on a PC

Possible Solution #1: (by Martyt, Starcraft 2 customer service)

There have been multiple reports of black screen issues being related to the use of a Quick Cam webcam.

In some cases exiting out of the software has resolved the issue but others have reported a need to uninstall the software for the camera in order to resolve the problem.

There are also reports where some security programs like Comodo firewall can cause the game to start and stay on a black screen.


So... Do you have a Quick Cam or Comodo Firewall?

Perhaps this could be the area to look out for,
it could look like something prevents SC2 from launching its older version properly...

  • I am using neither of these applications.
    – Oak
    Oct 10, 2010 at 13:00
  • 1
    Anything else? Have you tried disabling virus scanners? Does the event log say something? Does the same happen when you switch to your desktop and then go back to the application? Oct 10, 2010 at 13:53
  • what event log?
    – Oak
    Oct 11, 2010 at 13:55
  • Event Viewer from Windows. Oct 11, 2010 at 13:57

I had this problem as well.

The way I got around it was to launch the replay from within game by adding the replay to my replays folder:

My Documents/StarCraft II/Account/(your account number)/(more specific numbers)/replays/relevant_folder

  • I tried it and it didn't help, though that was a few versions ago... I'll give it another shot when I can.
    – Oak
    Oct 3, 2011 at 16:17

I also have this issue with Replays as well as games (all types); one second after the game begins (and looks fine) the screen goes black and the music and interactions continue but with no vision.

The issue revolves around my graphics card (NVidia GTX 1660 Ti) and the fact my laptop has two graphics drivers; an Intel default one and an Nvidia main one.

So, use your Windows Device Manager and disable (but do not uninstall) the non-main graphics drivers on your device, before starting Starcraft.

  1. Type “device manager” in the start menu and the option will occur. Click it.

  2. Find “Display Adapters” and open it up. It should show at least two options;

  3. Right click on whichever one is NOT your main graphics driver, and select “Disable”. Your screen may reset or windows may rerender. Don’t worry.

  4. Launch Starcraft 2, the game should run because SC2 now only uses the single main driver rather than trying to mix and match between the two.

PS. View a screenshoot of the Device Manager


So I'm not 100% sure if this is your problem but I do know this can be an issue:

Starcraft 2 keeps previous versions of itself around to support replays from previous versions. As a result if you update directly from 1.0 to 1.1 you can miss out on versions 1.0.1 through 1.0.3, and thus have those replays not work.

Now I know this has occurred, I don't know if Blizzard is flushing the in between updates (or now bundling them), or if this is even the problem you have.

Can you see other replays from the version in question?

  • I've tried the next game in that series - I guess that's from the same patch, then - and I got the same (black) results.
    – Oak
    Sep 28, 2010 at 17:28
  • Have you tried all the other ones? or series from the same time. I assume you mean this series
    – tzenes
    Sep 28, 2010 at 17:29
  • I've tried a few more and they all do the same.
    – Oak
    Sep 28, 2010 at 17:49
  • It sounds like this might be your issue. To resolve you could try reinstalling SC2 from an earlier version and then applying the patches one at a time. I'm not sure where you would get them... but I know some of the seedier parts of the internet might have them. Not that there is anything illegal about trying to obtain previous versions of the game you purchased.
    – tzenes
    Sep 28, 2010 at 18:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .