We're trying to play Dead Rising 2 on the same LAN, only to learn that Games for Windows Live expects you to forward 4 ports from your firewall to the PC. Obviously this isn't going to work in our situation. Has anyone found a good solution?


After a couple hours of additional net-scouring, we tried a lot of suggestions, and when it finally worked, of course we'd changed a few things. So, in our case the solution was one or all of the following:

  • Move the GFWL-required ports from port-forwarding (on the router) to port-triggering
  • Disable all non-related (virtual) NIC adapters (in our case, they were for VMWare & VirtualBox)
  • Make sure the firewall exception for DR2 is present in Windows Firewall

My money is on the port-triggering.

  • 2
    Thanks for coming back with the solution, and sorry we couldn't be of more help =^)
    – juan
    Sep 29 '10 at 13:26
  • No worries, I was VERY motivated to figure it out. There was zombie-stomping at stake! Sep 30 '10 at 12:33
  • I'd also try placing the PCs in the DMZ, which is the most comfortable solution, but also the riskiest.
    – DrFish
    Jun 8 '11 at 6:55

You'll have to change registry values: Games fow Windows Live Support

Look all the way down at the bottom at the Port Override section. Exact instruction are as follows:

  1. Open your registry in the Windows registry editor.
  2. Navigate to the following registry key: HKEY_CURRENT_USER\Software\Classes\Software\Microsoft\XLive
  3. Add a new DWORD value. Enter LivePortOverride as the name and the new port number as the value. This value must be greater than 5000 and less than 65535.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.