4

I have a low level reptilian hide breeches of the bear that I crafted for my level 9 character. Now, I realize I will probably be finding or crafting a better pair of pants very shortly, but I find it extremely annoying that I can't equip this item.

I have tried removing my currently equipped pants and dragging them in, opposed to simply right clicking to equip. I have tried dropping them and trying again, I have tried dropping them without leg armor equipped and picking them up with auto equip enabled. I have sold it to a merchant and then re-buying them. I have put them in my stash and tried to equip the pants on another hero, I've tried logging in and out, restarting the game, restarting the computer... obviously nothing has worked.

This seems like a pretty odd bug... I would like a work around because I don't want to have this happen to me again down the line.

Furthermore, this is kind of killing my interest in actually playing the game... I just want my pants so I can go kill the mad king... is this really that hard? It's way to early in this game to be worrying about such an insignificant thing.

1
  • 4
    I think your title should have been "I can't put my pants on!"
    – SaintWacko
    Aug 29, 2012 at 14:44

2 Answers 2

5

According to Blizzard's game guide, Hide Breeches have a minimum level of 11. Gain two more levels, and you'll be good to go.

4
  • the item says level required 9.... perhaps that's where the bug is
    – Joe
    Aug 29, 2012 at 2:31
  • Strange. My blacksmith says they require level 9 as well. I crafted a pair, and my level 10 Wizard could wear them without issue.
    – Frank
    Aug 29, 2012 at 2:34
  • I just tried it with a level 19 character and it was equipped with no problem...
    – Joe
    Aug 29, 2012 at 2:37
  • 1
    That link says they have an item level of 11 but a required level of 8. I've only just started playing D3 but I assume its like WoW and item level is not directly related to requried level.
    – Chris
    Aug 31, 2012 at 22:13
1

This was a bug where some crafted items were displaying the wrong minimum level. It was fixed in the 1.05 patch.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .