There are plenty of problems with SC 1 Broodwar running on Windows 7 Ultimate x64 like freezing, corrupted colors etc.

How to fix this?


10 Answers 10


The solution is to kill the explorer causing these problems:

  1. Open notepad and paste this in:

    @echo off
    taskkill /f /IM explorer.exe
    start /wait StarCraft.exe
    start C:\Windows\explorer.exe
  2. Choose all files -> save as WIN7FIX.bat

  3. Copy WIN7FIX.bat in the starcraft directory (where starcraft.exe is)

  4. RUN this bat file. DONE !

P.S. There are other guides on the net, but they miss 1 important thing: the wait switch. We have to wait until sc1 ends, otherwise the explorer won't start!

Extra Credit: If you don't like seeing a command prompt window open up when you run Starcraft, create a second file, however give this one a .vbs extension. Right-Click->Edit and paste in the following:

Set WshShell = CreateObject("WScript.Shell")
WshShell.Run chr(34) & "scFixed.bat" & Chr(34), 0
Set WshShell = Nothing

change scFixed.bat to whatever you named your batch file. Save and close the editor, and run the .vbs file.

Cleaning up

  • Create a shortcut for the .vbs file on the desktop (or wherever you keep your game shortcuts) and rename it if you wish
  • Right-Click and go to Properties->Change Icon
  • Browse to the Starcraft directory
  • Click on the original Starcraft.exe (with the Wraith fighter icon) and click Open
  • Click OK a couple of times

Hey Presto! a brand new (working) Starcraft shortcut that doesn't open a command prompt window

  • 1
    Anyways, I would recommend to combine this method with the Powerlord's method (the compatibility settings for Starcraft.exe). Just to be sure.
    – theSpyCry
    Sep 30, 2010 at 6:05
  • Anyways, this is a drastic method and I believe there is a less ugly fix. I've played with "selective startup" in "msconfig" where you can say BASEVIDEO boot only etc. Anyone succeeded with this?
    – theSpyCry
    Sep 30, 2010 at 6:08
  • Fwiw, this also fixed issues for me where the screen would go blank on certain briefings/playing certain videos. Thanks!
    – Amelia
    Apr 27, 2014 at 10:34

I'd have to check my exact configuration at home, but on my Windows 7 x64 Ultimate machine, I believe I have it configured like this:

On the Application shortcut's Compatibility tab, check the following checkboxes:

  • "Run this program in compatibility mode for Windows XP (Service Pack 3)"
  • "Run in 256 colors"
  • "Run in 640 x 480 screen resolution"
  • "Disable desktop composition"
  • "Run this program as an administrator" (if you want to play online)

This fixes the video issues in the menus, although they will reappear if you Alt+Tab out of the game then back in.

  • 1
    could be helpful for someone.. in my case it didn't help :/ ..
    – theSpyCry
    Sep 29, 2010 at 18:16
  • It turns out I have a few more settings set for SC on my home machine. I've updated my answer. Having said that, I played through the entire original SC Terran Campaign and half the original SC Zerg campaign without any problems using these settings.
    – user2974
    Sep 29, 2010 at 21:36
  • Does it help solve the freezing problems too?
    – theSpyCry
    Sep 30, 2010 at 6:00
  • @PaN1C_Showt1Me: I'm not sure. I wasn't experiencing freezing issues, so I don't have any way of testing that.
    – user2974
    Sep 30, 2010 at 13:06
  • This did fix this problem for me way back when
    – Resorath
    Jun 10, 2011 at 15:51

There are still people for whom all mentioned fixes WILL NOT WORK:

  • Setting Affinity (1 cpu in task manager)
  • Setting Process Priority
  • End tasking or pausing Explorer (this is my first answer which works in 80 % of cases)
  • Selective start-up (allowing just basic services in msconfig: start->run->msconfig)

My personal feeling is, that it depends on your graphic card.. the more powerful your graphic chip is, the higher probability it won't work.

For these people though, there are still 2 possibilities:

  1. Run Starcraft in a virtual machine (Windows XP Mode) <- which is ok, but you cannot get this old game full screen (no matter what you do, it resizes itself to 640*480 and leaves black borders around the game)
  2. Using the Chaoslauncher tool <- there is an option: W-MODE (windows mode)
  3. Using the DxWnd tool (which allows to run old games in a windowed mode). But please, do not forget to install the c++ redistributable first (it's the second link on the site: link). Then you can install the dx tool

The second (or the third) option is very interesting and should work for everyone ! It solves the Direct3D freezing problems with this game. It runs in a Window (which is a inconvenience for playing :-/ ), that means, that if you have a high resolution screen, lower your resolution to 800*600 (or something lower than your normal resolution) so that it won't be so small.

  • 1
    +1 for ChaosLauncher. I had all kinds of weird problems and nothing seemed to help. I installed ChaosLauncher and everything has worked flawlessly since. It even lets you run SC in windowed mode and handles automatic updates of the game files.
    – Jesse Webb
    Jun 10, 2011 at 20:49
  • The batch file solution does not work, but ChaosLauncher with its Windowed plugin works! Mar 13, 2015 at 9:57
  • DxWnd worked for me and I was able to play in a window, but I had to undo some of the changes I made to the Application shortcut's Compatibility tab settings as described in user2974's answer. (I still have the "run in compatibility mode for xp sp 3" box checked and "disable desktop composition" but otherwise turned it off.) Also DxWnd's generic option was the one that worked for me, not the one that had Starcraft in the option name. Apr 4, 2015 at 20:04

You can use a DirectDraw "hack" without stopping explorer.exe before launching the game. Just unzip the file ddhack10.zip into your Starcraft directory and run the game as normal.

An excerpt from the author of the hack as to why he created the workaround for DirectDraw:

My Win7 switched to 256 colors at a 640x480 resolution, but the game ran.. with completely wrong palette.

Seeing that the games use DirectDraw, I decided to roll my own.


The colours are easy to fix (just open up screen resolution window before starting sc)

But there is still the problem of freezing.

If i play in full-screen mode, my computer will freeze after a while. Mouse doesn't move, sound will continue to play until the end of the .wav (probably buffered in a realtek chip). Have to reboot system.

However I have never had this problem in windowed mode


If you have problems after installing NVIDIA driver update, go into the 3D options and turn if the setting called DPS in under the global tab. I found this solution on the battle.net forum.

Posted by SmearMerchnt I had this exact problem on my own machine (nvidia-based), where many moons ago the game worked fine and then it had the graphic issue you describe. It appears to be nVidia's default global settings for Dynamic Super Resolution (DSR) that were added during a driver update. I resolved this issue using the following method, it also resolved similar video issues I was having with games from GOG:

  1. go to the nvidia control panel
  2. in the left panel go to 3d settings -> manage 3d settings
  3. in the global settings tab turn off DSR factors (uncheck any boxes, this should also turn off DSR - Smoothness, if not turn that off too)

In the Nvidia control panel, adjust the desktop size and position. Then, for the aspect ratio, select "perform scaling on GPU instead of display" and apply the changes.

This will allow the Windows 7 user to run StarCraft and Diablo in their native resolutions.

  • 3
    Nice tip, but I don't see him saying he has an Nvidia Card. Does AMD has this alternative, too?
    – DrFish
    Jan 19, 2012 at 10:53

Blizzard Support: Rainbow or Washed Out Colors on Windows 7

If you are experiencing washed out or rainbow colors in the game, forcing Windows DirectDraw to run the game under a compatibility mode may resolve your issue. We have a pre-set registry key that you can apply to enable it.

  • 2
    Hi @finitor, welcome to the site. Please include a brief summary of what you're linking to and reformat the link text.
    – C. Ross
    Feb 12, 2011 at 16:04
  • This works for me like a charm! And it should be the accepted answer if I were the OP's owner.
    – Nam G VU
    Aug 10, 2011 at 3:21
  • Does it resolve the game freezing as well?
    – theSpyCry
    Aug 18, 2011 at 5:44
  • @user7051 link is now broken. Apr 4, 2012 at 8:12

For the corrupted colors issue:


You only need to run this once on StarCraft.exe. With this, there's no need to manually close, or use scripts that will close Explorer.exe everytime you run Starcraft.

Windows Vista and Windows 7 break color compatibility with certain applications that depend upon palette-based, 256-color graphics. Due to changes to DirectX and DirectDraw, the colors of these applications and games may appear distorted under these newer operating systems.

DirectDrawFix will allow you to resolve this specific issue by applying required compatibility fixes to the registry. Elevation is required for this application to perform its updates.


If it is just a color-rendering issue, the DirectDrawFix listed above (per galacticninja) fixes the problem without needing to manipulate the GPU management, OS compatibility or video driver issues at all, at least on Win7 Pro 64-bit.

Each main game .exe can be fixed independently without disturbing the settings of other games. I applied this fix for a few Microsoft games successfully but it works for all legacy games that had never applied a fix/patch themselves for the upgrades (probably lost support due to marketing senescence). The original Starcraft and its expansions fall into this category since the most current patch did not address the new rendering technology.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .