2

I just crafted a pair of shoulders for my level 11 Demon Hunter, and I can't get them equipped. I click or drag them on, and I hear the clink sound, but it stays in my bag. It's not class specific and I meet the level requirements. I tried crafting a different pair, but the results where the same. Exiting/re-logging in does not fix it. Does anyone know how to fix this?

  • if its not lag, it sounds like a glitch to me. – l I Aug 31 '12 at 1:37
  • 1
    Wait it out, I had a similar problem with pants the other day and they fixed themselves after a while. – authenticgeek Aug 31 '12 at 1:50
  • @yx: Yes, I think it's a glitch...I was wondering if there was a workaround, or if I'll be forever shoulder-less ^.^ – silvermaple Aug 31 '12 at 1:52
  • Screenshot of the whole mess, maybe ? – Nigralbus Aug 31 '12 at 8:20
  • @Nigralbus: Do you mean a screenshot of my shoulders sitting in my inventory? – silvermaple Aug 31 '12 at 21:09
1

Some word of mouth sources I've heard (including in the comments here) say this is just a glitch and will go away after a while. So, I decided to continue leveling, and upon leveling up to level 12 , I tried the shoulders again and it worked! The pant's level requirement was level 11. I've since noticed two things: One, my Wizard could not equip some pants whose level requirement was exactly the same level as him, and that my Barb had pants on that whose level requirement was exactly her level, and they were shaded in red. I haven't played her since the last patch so...

It seems that there is a bug that cropped up last patch (1.0.4) causing some (or all) gear's level requirements to be actually one level higher than the tool-tip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.