I just finished the whole civil war quest chain for the imperials, and since then I've had an imperial guy following me with his sword drawn. This wasn't too much of an issue at first, once I realized that no amount of reloading could stop it. He even follows into dungeons that normal followers can't but here is where the fun ends. Even though we are on the same side, as it were, if someone engages me in combat, he does too. The best part? He's immortal. He has no health bar so I can't damage him, but luckily, once I kill the main attackers he stops hitting me, but his sword is still drawn.

He goes with me everywhere though not when I fast travel. I'll be free from him for a bit, then he'd just pop up out of nowhere! Especially in my home. When I walk towards him, it cycles through imperial gibberish and "You never should have come here!" But i can't interact with him in any way.

I've been playing with him tagging along for about 6 hours now and he just won't leave any ideas what i could do?

I'm playing on the PS3 so I can't use the console.

  • 7
    I don't know, Chewie...Fly casual.
    – Steve V.
    Sep 7, 2012 at 11:54
  • 1
    Just to be complete. I would love it for somebody to also add the console commands to fix it on the PC for the people who have a similar problem but on the PC.
    – Ids
    Sep 8, 2012 at 16:43
  • @Ids I have the game on Xbox, so I don't know the console command for it. I would suggest trying my fix (it worked on Xbox and PS3, might work on PC), or finding a console command to completely delete a character (that character becomes useless after the civil war quests). Sep 10, 2012 at 13:09
  • @Ids For PC, try console command of 'killall'. If that fails, target him, and try console command of 'kill'. Cannot verify it works personally as I dont have the glitch, but it should work.
    – JClaspill
    Nov 9, 2012 at 21:16
  • Also die'ing seems to work as the game then reloads all the npc's. May 23, 2013 at 7:11

1 Answer 1


I've had this problem on XBox, where Hadvar, the imperial who helps you (after trying to execute you) at the start of the game, would continuously follow me wherever I went after completing the civil war quest. This is a fix I did, and it worked. First, move very close to him, up to the point where you are touching him. Then, save your game. Make sure you don't override a saved game in case this doesn't work. Then shut off your console completely and reload the game you just saved. This should fix your problem.

If this doesn't work, I've heard people say that this can be fixed if you crouch when touching him before saving.

Let me know if this works! It worked for me, and I think it will for you.

  • My pleasure! That is, in my opinion, somewhat of a gamebreaker; that guy is annoying! Sep 10, 2012 at 13:07
  • 1
    I am glad this glitch has been resolved. I don't play Skyrim too much, but it seems extremely annoying for stuff like that to happen.
    – The Man
    Dec 27, 2013 at 17:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .