I see random characters in the game list and in chat, and it doesn't look like an asian language :)

Is there something wrong with my PC?


  • Unless you live in Asia or know the languages, you should consider changing your gateway to USEast/USWest/Europe to find more people who speak a readable language. – Decency Sep 11 '12 at 2:55

StarCraft was written in a time before Unicode support became commonplace. As a result, it relies on the computer to work in the correct codepage - and as the Mojibake shows, your computer isn't.

What you can do is either to change your OS regional settings to use an appropriate language for non-Unicode applications (requires a reboot), or you can try to launch StarCraft through AppLocale, where you can select the language to be used for that particular application. Presumably, the text is supposed to be Korean (because hey, StarCraft), so you'd want to pick that. If you change the OS settings, you probably want to change them back afterwards (so your other non-Unicode applications work as usual).

If you're running Windows XP, you also need to enable support for East Asian languages in the regional settings.

Of course, none of that is strictly necessary to play, and unless you are actually able to read and understand the language, you might as well ignore this display "glitch".

| improve this answer | |
  • does this mean that koreans see random characters when I write in english? – Alexa Sep 10 '12 at 11:39
  • @Alexa: No, because it just so happens that for the basic English characters, all of the standard PC code pages assign the same values to these characters. However, if you start using diacritics or other non-Latin alphabets (e.g. Cyrillic), then those characters would appear incorrectly to a Korean person. – Michael Madsen Sep 10 '12 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.