Some steps I've taken:

  • Opened up port 443 on my router for my 360.
  • Deleted the Netflix app, then clear my Xbox system cache.
  • Some people have suggested that my Xbox could be associated with a different Netflix account, however, the last time I tried to make an account, I was not able to complete it because I did not have a credit card, thus I was unable to access the service. Even further, when I log into the old account on my PC, it gives me no information about any devices being associated with that account, plus my wife and I deleted absolutely every trace that we could of Netflix from the Xbox.
  • I have also gone into the developer/settings mode in the netflix application, and telling it to forget my credentials has had no effect on my next login.

We are able to log into the new account, but if we exit and start the application up again, we have to put in our login credentials again. My wife has an older Xbox that we were debating on trying to use, just in case it actually did end up that my Xbox is retaining some sort of information or Netflix associated the account with my Xbox and for some reason cannot disassociate it. When we tried logging in through this xbox, we faced the same problem.

Has anyone else ran into this problem (it's littered all over the internet with no real solution), and fixed it?

Update I had been on the phone with a Netflix support person for an hour trying most of the above steps, with no success, so they directed me to the xbox support. They had me do the same steps, and when it failed, they directed me back to the Netflix people. They had suggested that some of the netflix servers were having issues, but I don't think this is the issue for a few reasons:

  1. When I do put my credentials in, it logs me in first time with no issue.
  2. The only real problem is that Netflix isn't remembering my email/password, which should be part of the application logic, and is unlikely an issue networking.

In the remote chance that it has anything to do with the Netflix network, I'm in Ontario, Canada, and it must be something where after a successful login, the server is supposed to send the application a message like "everything is okay, you should store the users email/password," and for some reason, that message doesn't get passed or processed properly, and since this problem seems to be very infrequent among other users, I have to assume it's an issue with a server, even though it shouldn't be.

To any Netflix XBox 360 application developers: The application shouldn't wait for validation before saving credentials! It should be within the users own intelligence to be able to save the appropriate email/password information. It's not good support to have this on-going problem for months.

To people having the same issue, please leave relevant information such as your ISP and general location (city/region/country), as we might be able to collectively solve this issue. I am from Waterloo, Ontario, Canada, and my ISP is EyeSurf.

Update/Found the problem, not the solution: So, I finally got around to checking out the Netflix log, and I noticed this error:

SLPlayer|SilverlightNccpErrorHandler|Warning|Nccp AuthenticationRenewal transaction failure, new credentials requested, Code: 3037, Description: XUID is not associated with any customer

I did a google search for this error code and message, and only found one relevant post where the user is still stuck in the situation I am.

Update May 29, 2013

There was a Netflix update about a week or so ago, and since that update, my credentials have saved to my xbox live account for the first time, and have remained so for my last 5 logins so far. I think it's safe to say it's a fix. Has anyone else with this issue also found some resolution in the last update?

  • 1
    Sorry if this is the wrong place to ask this - couldn't really find a more relevant stackexchange oriented place to ask.
    – OzBarry
    Sep 11, 2012 at 20:55
  • Have you tried deleting the Netflix save file on your Xbox?
    – CyberSkull
    Sep 11, 2012 at 22:48
  • I deleted everything under "Games and Apps" associated with Netflix, and re-downloaded the entire application and updates.
    – OzBarry
    Sep 12, 2012 at 1:36
  • 1
    Just upload your saves to the cloud. Then do the steps to wipe your profile off the system and download it again. Problem Solved.
    – Ramhound
    Sep 13, 2012 at 12:29
  • 5
    @SteveV. This seems to be localized to his console, which makes it a question we allow. We're the best place to ask questions about wonky things that happen with your gaming console. I get what you're saying, but this is definitely the sort of thing we want to keep around.
    – Frank
    Nov 29, 2012 at 16:00

2 Answers 2


Open Netflix

Go to where you see the movies.

With the D-Pad, type in the following code

Up, Up, Down, Down, Left, Right, Left, Right, Up, Up, Up, Up

If you did that correctly, a new menu should pop up.

From there, you can resign in and it should keep your log-on.

Source: http://support.netflix.com/en/node/181

  • 2
    This support article tells you how to switch accounts, but the problem here is that the account is not being remembered, forcing a sign-in every time.
    – Coronus
    Mar 8, 2013 at 16:16
  • I thought I had already covered that I have tried this. I'll update the question to mention it. It didn't work.
    – OzBarry
    Mar 8, 2013 at 17:29
  • 2
    I had gone through the exact same situation. I was using a family member's account for a while, but got my own, but it never saved my login, no matter what i did, delete the cache, delete the app, nothing ever worked. Then i tried what my answer is and it worked and i haven't had to re-login ever since. Apr 3, 2013 at 13:02

I had this problem with my girlfriends Kindle Fire and my Xbox. We updated but it didn't correct the problem at first. After signing in on my console like 5-6 different times after the update, it finally just saved my log in without me having to do anything. With her Kindle though, we had to have her sign in, then we went on the computer while she was signed in and found the device manager thing on Netflix. From there we got Netflix to recognize the Kindle. No problems since. Netflix does some weird stuff like that every once in a while.

  • So is this answered?
    – Brok3n
    Apr 18, 2014 at 5:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .