I got the injector from Sir Hammerlock, injected the pod and this huge green badass thing popped out and killed me in the face. Now I can't find it nor can I inject another pod to achieve the same effect. The quest is still active asking me to kill the mutated varkid but it is no where to be found. What am I to do?

  • 5
    lol 'killed me in the face' .....
    – Zero
    Sep 28, 2012 at 16:35
  • Have you tried reloading the map? Save and quit and try again. That usually fixes these kinds of problems. Follow the quest marker.
    – Ids
    Sep 28, 2012 at 19:51
  • possible duplicate of Can I restart a side mission?
    – Wolf
    Oct 2, 2012 at 8:28
  • 2
    It killed me too (in the face, if you will). Two times. Anyone know if this mission is easier done in Co-op with two people? (I might be able to enlist another Vault Hunter.) Or will the difficulty just scale up, and you'll both die, anyway? Oct 2, 2012 at 16:15
  • 1
    @Sean I don't think this is a duplicate of that question. This question is about this specific mission only. It's not about how to restart this side mission. Also, as stated in an answer by Ben Brocka, there is a way to work around this specific issue for this mission (by creating another Mutated Badass Varkid). Oct 2, 2012 at 16:17

4 Answers 4


You can make more Mutated Badass Varkids; just inject another pod by using the Action key (E on PC). It does not show an action prompt for this, but you can still do it. You won't know if it worked until the pod hatches, just get as close as possible and press E/pick up a couple of times and wait for the pod to hatch. Since there's no visual indication, get ready to fight a Mutated Badass Varkid immediately after trying to "inject" a pod in case it worked. They deal Corrosive damage, resist corrosive (IIRC) and are weak to Fire.

You can also spawn multiple mutant badass varkids at once if you want to speed up the process. I strongly advise against doing that unless you're significantly overleveled for the quest (I take it you aren't).

You'll have to do it several times to make more mutants and kill them. It's awkward, but unless you've caught a glitch, it's still possible to hatch multiple mutant varkids. You don't need to find the one you made before (he's despawned by now and that's okay).

  • Actually it does show the action prompt :D. And damn those mutants are good at killing people in the face. The only way I can take own down is by emptying a rocket launcher in his face when already downed. (And then, forgetting to pick up the remains ;) ).
    – Ids
    Sep 29, 2012 at 11:40
  • Can you still mutate them after the quest is done?
    – Ids
    Sep 29, 2012 at 11:40
  • I have the same predicament and this does NOT work for me. I've been trying 20 or something pods and so far I still haven't manage to spawn a Badass Varkid. Seem like I have to skip it entirely.
    – Sandokan
    Oct 30, 2013 at 21:27

I had the same issue but after leaving the area for about 10-15 minutes and going back I finally got the prompts back.

Keep in mind you have to let the larvae go into the pods and then the command prompt comes up. If you mess up an adult comes up and if you wait even longer the adult eventually turns into a different (non-mutated) badass form.


Yeah, I was having the same issue. I got killed in the face many times. So I decided it was high time I figure what had happened, realizing it left I thought I was doing something wrong but the true solution is to leave the map save and quit then reenter and try again


On xbox it wasn't allowing me to inject after the first time so I quit and restarted then it allowed me to, as for killing faces I used my mecromancer and ran, kept my face intact lol

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .