This is probably a really stupid question, but I tried searching and could not find anything in either the help files or online.

Perhaps it is a bug, but I cannot gift any units to either city-states or other players. When I select gift a unit, the gift cursor appears, but when I click on a unit nothing happens. I tried moving the unit to their territory first but it does not work and it says that you can gift a unit from anywhere on the map.


5 Answers 5


I had a problem with this - make sure you're clicking on the hex tile at the unit's "base", and NOT on the circular icon for the unit. Clicking on the icon "selects" the unit and cancels the gift operation.


The unit does not have to be in their territory in order to gift it. Aside from the method GoatRider mentioned, you can go to the City-State's diplomacy screen, and then click on "Gift Unit." When you click on the unit you would like to gift, you should receive a confirmation asking "Do you want to give [city] your [unit]?" and an option to choose "Yes" or "No." If you choose yes, it takes three turns for the unit to reach the city-state itself.

You're apparently not receiving the pop-up confirmation. This may be a silly question, but are you sure that the unit you are clicking on to gift belongs to you? When you click on Gift Unit and your cursor changes, the hex of any units that you have eligible to gift will become outlined in yellow.

In addition, doing some testing here, it seems that you cannot gift Workers or Great Merchants (I'm not sure about other Great People as that was the only one I had to test with). If I tried with either of those, I had the same problem you did. I think perhaps combat units are the only ones eligible.

  • Also, I've personally found that this doesn't usually work with units that garrisoned in cities.
    – DMA57361
    Oct 21, 2010 at 20:58
  • 1
    You can only gift military units.
    – PeterK
    Oct 22, 2010 at 8:37
  • Giftable units have a yellow highlight around the hex base. Non-giftable units do not (e.g. scouts are not giftable by the looks of it). May 8, 2016 at 0:52

I'm pretty sure it has to be in their territory, otherwise how would it know which state to go to?

It works fine for me- I move a unit to another territory, click "gift", and it's no longer mine.

  • I mean you click on a city-state, and you can gift them money or units, so if you click gift unit the cursors turns into a gift, but when I click on a unit it does nothing, and I made sure it's a combat unit.
    – caretrain
    Oct 8, 2010 at 15:50
  • Oh I see what you mean, the menu item in the diplomacy screens. I've never used that, I'll give it a try sometime.
    – GoatRider
    Oct 11, 2010 at 20:03

You can only gift units they want which are usually not the ones you still have and are old. There will indeed be a yellow hex. If your having this problem, just click gift unit, then zoom out and assuming you have at least one unit from your era or so you'll see what I mean.


Are you trying to gift a non combat unit (like a worker or settler) or a combat unit (e.g. pikeman, frigate etc)?

You can only gift combat units. (Took me ages to figure out).

You must log in to answer this question.