I'm trying host Call of Duty 4 Modern Warfare on the internet but failed miserably even after troubleshooting.

I'm not sure if I've setup the process correctly. Here it goes.

I've a Netgear N150 WGR614v10 router and Windows 7 operating system.

  1. I've set up port forwarding in my router with TCP/UDP on port 28960.

  2. I've also allowed port 28960 in the Blocked Services from my router.

  3. I've disabled Windows firewall and antivirus and SIP AGL and allowed port scan and ping on internet port.

And after running COD server I then tried to find open port on http://www.yougetsignal.com/tools/open-ports/ but it said that my port 28960 is closed.

I'm stuck and can't find any solution to this problem, please help!

port forwarding

block services

wan setup

  • 1
    Try using the full port range (28960-29000).
    – Krazer
    Commented Oct 2, 2012 at 15:38
  • Do you also have a modem? If so does the modem also have a firewall? Have you disabled windows firewall? Commented Oct 2, 2012 at 16:04
  • @Brent Hacker I don't have a modem.
    – Searock
    Commented Oct 2, 2012 at 16:43
  • @ Krazer I've tried adding the start port as 28960 and end port as 29000 but still no luck. I found in TCPView that iw3mp.exe had UDP PORT 28960
    – Searock
    Commented Oct 2, 2012 at 17:01
  • Two things. Firstly, did you make sure that the server computer will always be assigned Secondly, port checkers won't return an OK unless there's a service actively listening on the port. Did you make sure that you checked the port while your CoD server was active?
    – Schism
    Commented Oct 4, 2012 at 21:42

2 Answers 2


But how are you sure that the server isn't working?

Have you tried to connect to that server using your external IP (no the 192.168.#.# IP) from another computer?

Or you just want to host a LAN server?

Try to ping your own external IP from another computer using the following command in the command line of windows (to open it press Windows Key + R and the write cmd and then press enter):

ping YOUR IP:28960

example if your ip is then write in the command line:


If you server is online, you should receive response. Maybe try with and without the :28960, just in case.

To know which is your IP go to http://www.whatismyip.com/

Also, to discard problems, maybe it would be better to do all this without the router, I mean if you have a router and a modem connected to your router, connect the modem directly to the PC (you may have to create a new connection, maybe PPoE or another, depending how is configured your internet service), to reduce the number of possible variables that are impeding you to host the server.

Also another problem you perhaps have is something that happened to me when I used to host a LAN server on my computer. I started hosting the LAN server but the first time I configure everything and have the console of the server running, from the other computers they couldn't connect to it...

And what was the solution? Without closing the server, open another instance of iw3mp.exe and host a new server... and the close the first one. Doing that, I could connect from the other LAN-computers, I don't know why was that, but I solved doing that.

Finally, do you have your cod original? Because if it isn't, I think hosting a server doesn't work in the traditional way that does the original, you have to download a modified server file iw3mp... but of course, I can't provide you any link and also it's illegal.

  • I've tried to connect to the server using the same PC and I have original copy of COD. I don't have a modem at all, just a router. I'll try your second option of running another instance. Thanks for your response.
    – Searock
    Commented Oct 10, 2012 at 6:26
  • I would highly recommend doing the "connection tests" from another PC, of course if you have the possibility.
    – mp19uy
    Commented Oct 10, 2012 at 19:50
  • I was able to connect using Hamachi.
    – Searock
    Commented Aug 16, 2013 at 9:59

The alternative to port forwarding is to setup a private VPN using Hamichi or Tunngel.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .