4

I'm trying to play Minecraft on my 64 bit HP dv6, with a Core i7 3rd gen. processor and a Nvidia Geforce GT 630M graphics card. I am able to play games such as Borderlands 2 without any lag at all, but when I try to play Minecraft it is really, really slow and laggy. I have 64 and 32 bit Java installed. I also have 8 GB of RAM. Any ideas to make it run smoother?

4
  • 2
    Are you sure Minecraft is even using the nvidia card? Java/Minecraft doesn't automatically make the graphics switch to "high performance" on many laptops. Oct 4, 2012 at 4:09
  • I'm not sure. I'm kinda thinking that this is a pretty stupid question (my question). I have tried some other things and I think I should be able to get it running at least a little better, so I might end up closing this question
    – Kecoey
    Oct 4, 2012 at 4:20
  • Are you playing on a remote server? Could it just be network lag?
    – fredley
    Oct 4, 2012 at 8:30
  • No, it happens in single player
    – Kecoey
    Oct 4, 2012 at 14:19

1 Answer 1

4

Considering you have a laptop i would say the issue lies with the fact that minecraft doesn't automatically use your main videocard but instead uses the crappy intel video card.

To solve this you have to open your nvidia control panel then go to manage 3D settings and then select program settings then add javaw.exe located in your java/jre7/bin folder and select the high performance nvidia processor instead of integrated graphics. Now just press save and close the control panel.

2
  • i know pretty much for a fact that this is your problem seeing i have had the exact same thing happen to me and solved it by doing exactly this Oct 6, 2012 at 2:28
  • Sorry I never accepted this answer. I guess I just forgot to. Thanks btw I'm pretty sure that fixed it
    – Kecoey
    Jun 11, 2013 at 2:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .