I'm playing Oblivion on the Xbox 360 (so no console). There is a common problem when it comes to locating your horse after wandering around yourself, which is usually solved by fast-travelling to any city, or the city where you bought it. [1] [2] [3]

I left my horse outside the Imperial City (not in Chestnut Handy Stables) and when I came out it wasn't there, nor in the stables, despite a message saying that it had been stabled. I still have 1 horse in my horses owned count, so it hasn't died.

Since then I have fast-traveled to several cities, including Anvil where I originally bought it, and I always get a message saying that it has been stabeled, but when I go to the stables, it isn't there. I have also checked other city entrances, because apparently it doesn't neccessarily appear in the stable if there is another entrance closer to where you came from.

Still no horse despite the stabling message. How can I find it?


I was fast-travelling to the stables, not the cities. When I fast-travelled to the city where I first lost the horse, and then walked to the stable myself, my horse finally appeared!

(Glad it didn't turn out Snak gra-Bura ate it.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.