I've been experiencing a crash on startup with my copy of Borderlands 2 through Steam. It all started when I had to forcibly restart my computer while Borderlands 2 was open (note: the restart was required by a non-game related issue).

When attempting to launch the game again, I got a fatal error with a Windows AppCrash message and a stack trace in the image below. I've also got some memory dump files I can post if someone thinks they'd be useful.

  • Windows 7 x64
  • Sandy Bridge 2500K
  • 2GB Radeon 6950

Things I've Tried

  • Verifying Borderlands 2's cache
  • Uninstalling and reinstalling Borderlands 2
  • Uninstalling Borderlands 2, clearing all registry entries containing Borderlands, deleting %USERPROFILE%\Documents\My Games\Borderlands 2, uninstalling Steam, reinstalling Steam, reinstalling borderlands.
  • Check all audio drivers for updates
  • Uninstall and reinstall all audio device drivers

At this point, I'm worried my only course of action will be to reinstall Windows, which I'm not incredibly keen on. I've also emailed 2K and Gearbox support, but in the meantime I'm hoping someone has seen this same problem and found a less drastic solution than reinstalling Windows.

AK::SoundEngine::StopOutputCapture() AK::MemoryMgr::GetPoolName() AK::MemoryMgr::SetMonitoring() CreateAudioInputSourceParams() BaseThreadInitThunk() RtInitializeExceptionChain() (filename not found)

  • Probably one of the better technical support questions I've seen!
    – Niro
    Commented Oct 23, 2012 at 0:03
  • 1
    I was going to say force an update on your Borderlands 2 files, but it seems you've done that and more already. I agree that it definitely looks to be an issue with audio, but more specifically with your microphone. Try disabling all audio input sources.
    – MBraedley
    Commented Oct 23, 2012 at 0:25
  • 1
    Maybe it's not the installation that has gone bad, but your configuration is corrupt? Try moving all config files out of their normal locations (as backup) and try running again. i.e., the files in %USERPROFILE%\Documents\My Games\Borderlands 2. Commented Oct 23, 2012 at 0:34
  • 1
    @DaveMcClelland Do you experience the crashes after the "Preparing to Launch" window? If you do, try this: Create a .txt file in notepad and write the numbers '49520' without the ' '. Save it as 'steam_appid.txt' and save it in your Steam directory 'Steam\steamapps\common\Borderlands 2\Binaries\Win32' and run Borderlands2.exe as admin. (Source) Commented Oct 23, 2012 at 3:16
  • 2
    I'm going to guess bad memory stick due to the loops in the memory manager. Try due memory stress and/or benchmarking tests, reseating, swapping memory slots and/or removing one, trying different memory sticks. What was the "non-game related issue" that forced the first restart? Was it a hardware exception? Do you have problems with any other games? Any other UT engine games? Also, have you tried clearing CMOS and removing all power from the device? (Not sure if that still helps these days, but years ago that would help memory issues.)
    – Mufasa
    Commented Oct 23, 2012 at 3:17

2 Answers 2


After nearly giving up, I found the answer on Gearbox's forums.

From the post:

  • Delete Borderlands 2 in Documents/My Games (not WillowEngine.ini)
  • Stop cloud storage in Borderlands 2 Steam properties
  • Verify cache in properties
  • Activate the nologo option :
  • Launch the game and turn off automatic detection in launcher's config (put all options in off or lowest possible)
  • If the game start, it will create a new profile.bin... Quit the game and put your saves (not the corrupted profile) in the correct folder. Restart the game.

It does seem that this causes the well known issue that causes badass rank to get reset, however. The Gearbox forum post listed above provides information on how to manipulate it using Cheat Engine, but I'm personally going to wait and hope for them to release a fix that recalculates it automatically.

  • Oh right, the cloud... I knew the data was corrupt. Commented Oct 25, 2012 at 0:56

I was getting exactly the same problem and the way to fix it is to restore your profile.bin file in your saved game folder to an earlier version. C:\Users\%userprofile%\Documents\My Games\Borderlands 2\WillowGame\SaveData\76561197969377489

I did that and it fixed my game.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .