0

I find that when playing Amiga games in WinUAE, the sound goes choppy for no apparent reason. Sometimes this happens right away when starting emulation, other times sound is fine for a while then starts to go choppy at some apparently random point. Is there anything that can be done to prevent this from happening?

My system:

  • Windows XP SP 3.
  • AMD Athlon 64 X2 Dual Core Processor 4400+, 1.98GB RAM, NVIDIA GeForce 6100 nForce 405.

Some more details:

  • I am using version 2.3.2.0, but have also tried 2.4.1 and had the same result.
  • I've changed settings, such as sound buffer settings - but this doesn't appear to help.
  • The problem appears to happen with any game - not just a specific game.
  • The SND: value at the bottom of the WinUAE window often goes negative and is sometimes greyed-out. What does this mean?
  • I don't have any sound issues when using other non-WinUAE software on the same PC.

3 Answers 3

0

WinUAE uses the QueryPerformanceCounter function for timing, and it may be inaccurate on some systems as described here.

0

Sometimes the emulator is configured with "direct draw" to render the video, and sometimes it resets itself to this default value when upgrading the emulator.

direct draw is just software rendering and super slow. Even on an i7 the result is choppy sound and crawling game. Changing to "hardware direct 3D" solves the issue.

enter image description here

-1

I may not have the answer you are looking for exactly, but I will try to help. I had choppy sounds with some games and I tried a lot tweaking before. Some games and demos were really difficult to get to work 100% soundwise.

Later I activated the F12 WinUAE menu from the Option Tab. This means I can use F12 to go to the detailed tweaking screen and test all the options quickly. When I go to Settings - Host - Sound and change the first option, for me it said DSOUND Primary Sound Driver and then Realtek. I have an old Acer with no graphics card and 2GB memory, a dual core 2.1Ghz Cpu. Now I got games like Awesome running perfectly even soundwise.

I still get choppy sounds though, when I multitask, but I don't mind that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .