This problem has been bugging me for the best part of half a year now, resulting in me not being able to play one of my favourite games. It all happened around the time I got the DLC for Fall Of The Samurai.


  • Click on icon to launch Total War Shogun 2 in Steam
  • Game asks to start in Direct X mode (Dx9 or Dx10 is enabled)
  • Select either one and the game loads to the Loading / Legal screen.
  • Wait for 10 minutes and the game is still on that screen.
  • Ctrl+Alt+Del to desktop and see that "Shogun 2 is not responding" in task manager.

Computer Specs (DxDiag)


Things I have tried

  • Updated Sound and Graphics drivers
  • Updated BIOS for motherboard to latest version (1.2)
  • Reinstalled Shogun 2 on steam
  • Verified Game integrity on steam
  • Changed graphics cards
  • Searched Registry for "Incredibar" malware , not found on system
  • Disabled SLI on Nvidia control panel

All of these have not solved my problem.

I am really running out of ideas what to do here. It makes no sense why this does not work.

Any help would be appreciated!

1 Answer 1


This turned out to be a problem with my motherboard's northbound chip set between the CPU and Memory.

A replacement of it along with a newer AMD Quad Core processor resolved my issue. I have used the same Memory and GPU.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .