I'm playing the new Prison Architect Alpha, but as soon as I'm out on my own, after the introduction, I cannot seem to meet ANY room requirements.

For example - A holding cell... The requirements are that the room must be 5 x 5 in size, contain a bench and a toilet. I have done this. I have done this in numerous configurations. With doors, without doors, toilet connected to water, toilet unconnected, lit, unlit, a room IN a room. I've even tried building a 15 x 30 size room with those items in it. When that didn't work, I tried putting one of pretty much EVERY item in it. And yet that little flashing red triangle remains...

What am I missing?

  • I haven't tried the new alpha build yet, but I'll poke around with it when I get home tonight, see if I can reproduce the problem.
    – Frank
    Nov 5, 2012 at 18:24
  • I just tested this, and a holding cell builds fine. Can you add a screenshot of what you have?
    – Frank
    Nov 5, 2012 at 22:49
  • 1
    I'm seeing the room and the warning message, but I'm not seeing the crosshatching that designates which rooms are which.
    – Frank
    Nov 6, 2012 at 1:48
  • 2
    I was just looking through the changelog for Alpha 3 on the wiki, and it said there were some known issues with MacOSX running it through parallels. Installed it on Bootcamp, and is now working perfectly! Again, thank you so much for you help. You led me to investigating other possibilities after you confirmed it was working.
    – Ollie
    Nov 6, 2012 at 1:51
  • 2
    The isue with the question has nothing to do with MacOS. It is a problem of expected behavior by the user versus implemented behavior. Check my answer.
    – Mindwin
    Jan 5, 2014 at 13:25

3 Answers 3


I will consider the image you posted on question comments As part of the question.

OP Holding Cell Screenshot

The problem is: you have to draw a 5x5 square to make the holding cell. You only drew 1x1.

I had this problem also, I thought the game would fill the room up to the walls if I mark a single square as a room. It was an expected behaviour that was not implemented.

You have to use the room tool and drag a square 5x5 to make the room. The objects can be placed before or after that.


Issues with running Prison Architect through Parallels (MacOSX). Installed on bootcamp, problem no longer exists.


I think I might know. I am still investigating if this is actually true but here's my results so far. 1.You need to build a (as I call it) "loose" room by of course building foundation in the required area, (for example, 5,5 for a holding cell) but, you HAVE to NOT make a fake wall by connecting the building to a fence or another building or object as a side wall. 2. Do NOT have outdoor only flooring or dirt flooring inside of your building (not including a yard). 3. You MIGHT have to complete the tutorial and do ALL of the optional parts. Like I said,I am still investigating this,but when I figure it out I will inform you of it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .