8

Every time I run Dishonored under Steam I get a pop up asking me for my Administrator password (I run as a normal user account, I imagine a UAC prompt would come up if I was running as Admin). I think this is due to the Steam first-time setup being run every time.

In response to comments:

  • No other Steam game has this issue, only Dishonored
  • It's installed on a mechanical HDD, while Steam is on an SSD
  • I am running a Steam Beta which allows selecting a different install directory
  • My Windows user account is not an admin (hence the UAC privileges popup appearing)

Is there any way to correct this issue?

1
  • Shows how long it has been since I last played. Just started playing again yesterday. It installed an update, played, played today then BAM! Nov 15, 2012 at 2:00

1 Answer 1

9

You will need administrator rights to apply this fix

According to a Steam forums post:

You should launch regedit (runnable via Win + R) and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Valve\Steam\Apps\205100, right mouseclick on the right pane and click "new DWORD" (32-bit), name it "PhysXRedist" and give it a value of 1.

Restart the game and it shouldn't bug you anymore.


If you don't feel comfortable going into the registry yourself, run one of these commands instead depending on your version of Windows:

32-bit Windows:

reg add HKLM\SOFTWARE\Valve\Steam\Apps\205100 /v PhysXRedist /t REG_DWORD /d 1 /f

64-bit Windows:

reg add HKLM\SOFTWARE\Wow6432Node\Valve\Steam\Apps\205100 /v PhysXRedist /t REG_DWORD /d 1 /f
1
  • 2
    UAC will always point you to the "Admin or else" dialog.
    – DrFish
    Nov 9, 2012 at 16:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .