I'm trying to install Minecraft on a new computer, but whenever I try to run Minecraft.exe I get a message that says "The registry refers to a nonexistent Java Runtime Environment installation or the runtime is corrupted. The system cannot find the path specified." I tried reinstalling Java, automatically removing the old version, but I still get this error. How can I fix this?

  • 1
    The first hit on Google for that error message is to a minecraft forum thread. Have you tried the solutions at the bottom of that page? Nov 9, 2012 at 3:49
  • A newer version of the Minecraft Launcher uses a customized version of Java 8 which is built into the client. This removes the requirement to download an install Java to play Minecraft.
    – MisterBla
    Jan 9, 2015 at 16:33

3 Answers 3


The following should work for windows:

  1. Go to Start>Run>cmd.

  2. Type java -version and press return.

  3. You should see something like this:

    java version "1.7.0_05"
    Java(TM) SE Runtime Environment (build 1.7.0_05-b06)
  4. Make a note of the second number on the second line (eg: java version "1.7.x_xx" --> 7.

  5. 64 bit only: Check whether you're using a 64 or 32 bit version of java by looking in C:\Program Files\ and C:\Program Files (x86)\ for a folder called Java. Inside this folder there should be another which corresponds to your version number above. This should be jre? where the ? is 7 in this case. If you cannot find a jre? folder in the Program Files directory, then you do not have the 64 bit version of java installed. Go here and grab the Windows 64 bit version, then install it.

  6. Windows XP: Right click on My Computer, select Properties, then select the Advanced tab.

    Windows Vista or 7: Right click on Computer, select Properties, then click on Advanced system settings.

  7. Click Environment Variables.

  8. Under System variables click on New.

  9. Enter JAVA_HOME as the Variable name and C:\Program Files\Java\jre? as the Variable value, where ? is the version number from earlier (7 in this case).

  10. Click OK to close all the windows, then try running Minecraft again.

  • According to the thread I linked to in a comment to the question, people with this problem report that trying to run Java even to check version will give an error, so this answer likely stops helping after step 1. Nov 10, 2012 at 16:51
  • 3
    @SevenSidedDie or skip steps 1-5 and instal java then recheck the path for the JRE and continue from step 7 Nov 11, 2012 at 0:30

To fix the command prompt error in step one (I was stuck on step one for a while). Right click computer and choose properties. Go to advanced system settings and then click environmental variables. Find the variable title and add ";C:\Program Files (x86)\Java\jre7\bin" That'll get you to the next step of the process. I'm still experiencing the same issue with java. I can't start the minecraft.exe file.


In my case, system variables were not the problem. I solved this issue by doing the following steps (for a windows machine):

  1. Search for and delete the 'javasoft' folder in the registry
    • You can find your registry editor by typing 'regedit' in the Start search-bar.
  2. Delete the 'sun' folder in the windows directory and the 'users/appdata' folders
    • Mine was in the 'LowcalLow' subfolder
  3. delete any 'java' files from 'windows/system32'
    • For me this included 'java.exe', 'javaw.exe', and 'javaws.exe'.
  4. reinstall jre

Additional notes that might be useless: I did not have to restart my computer to see the effects of these changes. I executed these steps in the numerical order listed. Once I finished these steps I immediately started up Minecraft.exe to find success.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .