I have been continually plagued by graphical glitches. I've tried every combination of drivers, various settings on OptiFine, settings on the Control Center, but nothing has solved the issue. I've googled and tried about every solution I could find. It doesn't matter what texture pack I use, whether fullscreen or windowed, or whatever. After a few minutes of playing on any server or single player world, I will begin to get these annoying stretched texture graphics that cover parts or all of the screen, as well as "xray" holes in the floors and walls:

enter image description here

enter image description here

enter image description here

Specs / Info:

  • Windows 7 64-bit
  • i5-2500 / 8GB ram
  • ATI Radeon HD 5670 (Latest Driver - version, Anti-Aliasing = application defined)
  • Java 1.7 64-bit
  • MineCraft 1.4.2 + OptiFine

Any ideas or input would be greatly appreciated!

  • 2
    Have you experienced this in other games?
    – Sadly Not
    Commented Nov 14, 2012 at 3:04
  • 2
    Does this occur in unmodified Minecraft, without any mods? (Also, your specs leave out OS, which may be relevant. A recent MacOSX Java update had unpleasant effects on Minecraft, apparently.) Commented Nov 14, 2012 at 4:59
  • Sorry, I added the OS in (Windows 7 64-bit). I haven't tried an unmodded MineCraft in awhile, so I can try that this week.
    – mellamokb
    Commented Nov 14, 2012 at 14:17
  • I know it's been almost a year, but sadly I still have this problem lol. It happens even in a brand new install of unmodded Minecraft. I've played at least the following games on this computer without any similar issues: Portal 2, Titan Quest, Metro 2033, Quake III Arena, Anti-Chamber.
    – mellamokb
    Commented Sep 29, 2013 at 20:31
  • More references to others having the same issue: 1, 2, 3, 4
    – mellamokb
    Commented Sep 30, 2013 at 20:36

1 Answer 1


I usually don't have this affect when installing mods like Optifine, however sometimes they just fail to completely install.

It's a longshot but perhaps utilising a texture pack will fix the problem.

Otherwise try reinstalling Minecraft and the mods - remove all files under .minecraft from %APPDATA%, just remember to copy over your saves. Once Minecraft has downloaded all the files it needs, re-install your mods.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .