I got BF3 Premium Edition through Amazon and started downloading through Origin, and now whenever I get to 95% it stops and says error code 262145:5 and just stops. It'll download maybe 100 kilobytes of the game.

So I Contacted a chat agent in Origin, and I've tried everything. Ending Processes, Windows Update, Opening Ports, etc. etc. Nothing changed anything.

Here is the incriminating line from the file Client_log.html from the folder C:\ProgramData\Origin\Logs. It looks like similar problems with this .dll causing interference in other games such as ME2, BF2, etc.

159 [Nov 14 22:13:58.775] Error Origin::Downloader::UnpackStreamFile processPartialChunk [4980] Error opening file "C:/Program Files (x86)/Origin Games/Battlefield 3/Core/awc.dll". (5)***

This means that the awc.dll is interfering with the installation process in some way, purposely interfering with Origin to cause some lockup. The exact reason why this is I do not know.

Also to note is the following from the file Client_log.html from the folder C:\ProgramData\Origin\Logs.

88 [Nov 14 23:18:45.296] Warning Origin::Downloader::UnpackStreamFile tryResume [1140] A decompressor should exist but didn't. Redownloading: C:/Program Files (x86)/Origin Games/Battlefield 3/Core/awc.dll
89 [Nov 14 23:18:45.296] Warning Origin::Downloader::UnpackStreamFile tryResume [1140] A decompressor should exist but didn't. Redownloading: C:/Program Files (x86)/Origin Games/Battlefield 3/Core/EACore.dll
90 [Nov 14 23:18:45.296] Warning Origin::Downloader::UnpackStreamFile tryResume [1140] A decompressor should exist but didn't. Redownloading: C:/Program Files (x86)/Origin Games/Battlefield 3/Core/libeay32.dll
91 [Nov 14 23:18:45.296] Warning Origin::Downloader::UnpackStreamFile tryResume [1140] A decompressor should exist but didn't. Redownloading: C:/Program Files (x86)/Origin Games/Battlefield 3/Core/ssleay32.dll
92 [Nov 14 23:18:45.296] Event Origin::Downloader::ContentProtocolPackage TransferIssueRequests [1140] [ContentID:71067] Total requests: 10 Submitting: 10

It reads like these files may be interfering with Origin as well, but not as directly as awc.dll.

I have also tried:

  1. Go to the directory C:\Program Files (x86)\Origin Games\Battlefield 3
  2. Find the file named bf3.exe_DIP_STAGED, delete this.
  3. Go to the directory C:\Program Files (x86)\Origin Games\Battlefield 3\Core
  4. Find the file named activation.exe_DIP_STAGED, delete this as well.

Then, you should start the download again. When I watched the Battlefield 3 Installation directory the file should reappear, but ignore that and let it load. This atleast started the download again for me, but it stopped shortly after the bf3.exe_DIP_STAGED got to the full file size again.

You may be able to slowly build onto the installation by deleting the two files mentioned above, waiting for the download to stop, and repeating..it adds on a little each time. Still, there must be a more permanent solution..

I tried to download this .dll (media fire.com/?c21lz2pdmfd93b8) to see if it had any affect on the problem, and it did not. However, it may work for some of you. Continuing on.

All of the collective research I've done on this problem has led me to believe that it's an issue with the files activation.exe_DIP_STAGED and bf3.exe_DIP_STAGED overflowing in some way due to a flaw in the awc.dll. That sums up what I'm pretty sure is the source of the mess.

A good example of this problem is here: >>forum.ea.com/eaforum/posts/list/45/8819321.page#25104257

Failed solution here, might help some of you out.


I'm sending in my .log files from ProgramData and a Task Manager screenshot to the email posted by EA on this page >forum.ea.com/eaforum/posts/list/7363450.page I'll also be including a link to this page just to show them how detailed and in depth this problem is and that it needs to be fixed.

Yet another possible solution here, yet this one shows real promise - forum .ea.com/eaforum/posts/list/7650451.page This tutorial makes it so you can't access the Battlefield 3 folder itself, so instead of having to delete the files already downloaded it does it for you. Or something similar to that, read it for yourself. After trying this, I was put at 800MB downloaded (%4) and I guess I'll just let that run all night and tell you all how it turns out in the morning.

  • They just kept suggesting the generic solutions, you know, restart, update, disable firewall, etc. Never even asked for a log file or anything. Commented Nov 14, 2012 at 23:33
  • 1
    And I just discovered the dll is rouge/broken, haven't attempted to contact them about it yet. However, since I haven't had any luck with them, I figure this could be better. Commented Nov 14, 2012 at 23:34
  • @fbueckbert tried that, same thing. May work for other people but not so for me. Commented Nov 15, 2012 at 0:10
  • You've completely uninstalled Origin, deleted whatever residual files are left (including your BF3 download), rebooted, re-installed Origin, and downloaded BF3 again?
    – Frank
    Commented Nov 15, 2012 at 0:12
  • 1
    possible duplicate of Battlefield 3 Origin Install issues - error 262145:5
    – MBraedley
    Commented Nov 16, 2012 at 12:48

2 Answers 2


Apparently this particular error is something related to Origin, rather than specifically Battlefield 3. While I haven't found an instance of the error occurring related to the awc.dll library as per your error log, there is a suggestion over on the Origin forums that Battlefield 3 comes with its own repair tool, and that by running the repair tool it is possible to fix this problem specifically for Battlefield 3. The repair tool can be found inside of the Battlefield 3 installation folder within your Origin folder.

The below are other potential fixes for error 262145:5:

There is a forum post over on the Electronic Arts/Origin forums that suggests this is an issue relating to trying to install the game while using Windows 8. The suggestion given by EA support is to run Origin in Windows Compatibility Mode for Windows XP.

If you're not using Windows 8, there are a few other suggestions from EA support such as completely reinstalling Origin. Alternatively this thread suggests a DLL issue which can be resolved by replacing the relevant DLL (in this instance msvcp71.dll) which may also resolve your issue.

Finally, there is this existing question on Arqade for the same error which simply suggests uninstalling your current attempted install for Battlefield 3, and reinstalling it again through Origin.

  • It looks like from the edit I just posted (which you may or may not have seen) that it appears to be a rouge dll causing the issue. Also, I'm running it in Windows 7 x64 (Ultimate) Not Windows 8. Either way, I'll try Compatibility Mode. Commented Nov 14, 2012 at 23:32
  • I haven't found a single instance of error 262145:5 relating to awc.dll on Google, it actually returns no results at all. There are quite a few instances of this happening on operating systems that aren't Windows 8 so that might be EA support making assumptions
    – kalina
    Commented Nov 14, 2012 at 23:40
  • 1
    Apparently BF3 has a repair tool inside the installation folder, see if you can find that and run it - it should work similar to Steam's method of 'verifying game cache'
    – kalina
    Commented Nov 14, 2012 at 23:50
  • This is another google search for a different part of your error log - this points to the same error you're seeing in your error log but for MoH:Warfighter, the support representative from EA simply says "contact support", which I found particularly "helpful"...
    – kalina
    Commented Nov 14, 2012 at 23:59
  • I've just deleted all these files and everything worked fine.The download is running well. Commented Jan 5, 2013 at 13:28

I opened Origin, then deleted awc.dll under C:\Program Files (x86)\Origin Games\Battlefield 3\Core\

I then used Origin to repair my install - right click on game in My Games -> Repair Install.

Battlelog and BF3 then worked fine for me. Hopefully this might help someone else too. I am running Windows 8 64bit.

Edit: The tip-off for me is if you run the game via Origin you get a more descriptive error message about the awc.dll not being designed for Windows. This is obviously false. Also, the original dll was 1KB smaller then the eventual dll that worked but this might just have been coincidence.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .