I have Hearthfire and bought the plot in Morthal. After arriving and building the initial "small house", nothing appeared. There was just a blank empty plot. After porting to other towns and disabling my mods, I got the house to sort-of appear, but not really. Some of the walls are visible, and some of them aren't there at all, and there's no door to enter the house.

I've tried building more of the house in an attempt to force it to update, but all that does is add more walls. I've tried porting to other towns and restarting the game and it hasn't helped. It still looks like this with all mods disabled. Some screenshots:

enter image description here

my house

My last save is from a couple of hours before all these troubles began (I only really use quicksave to make frequent saves). If I went back to that save and worked my way back to this point sans mods, is it likely it would work? Or is my save completely messed up?

  • 9
    Daytime screenshots are usually more useful. :) Nov 19, 2012 at 17:33
  • 1
    It shows what's important: That there's no roof or door and half the walls are missing. I'm not sure what more information a daylight shot would give.
    – victoriah
    Nov 20, 2012 at 7:50
  • 3
    Not everyone is reading on a nice big, bright screen in a dark room. :) Some of us are using a tiny pocket computer on, say, a bus during our morning commute or something. I don't really understand looking for help but provide screenshots where there's no light. (I'm merely giving some advice, just in case this question doesn't gather the attention you expect—improving the screenshots might make just enough difference. If you get your problem solved with these ones, then hey, no need to change them!) Nov 20, 2012 at 18:06

3 Answers 3


I have found that building no more than 1 object per second eliminates virtually all bugs associated with items not showing up. I would suggest making a hard save, reloading to the previous save, quickly buying a plot and building a house bearing my advice in mind.


I tested buying a different plot of land and building a new house and I had the same issue. It seems that once a save file has gained this kind of corruption, it applise to all houses you build on that save.

So the only way I found to resolve this was to go back to a much older save. Then I did what @kotekzot suggested and built my new house one piece at a time. I took much longer than one second per object to build; I exited the menu and confirmed each piece had been added before I built a new one.

  • 1
    Why didn't you mark kotekzot's answer if his suggestion is ultimately what solved your problem? Dec 22, 2012 at 2:29
  • Because (a) it's not what solved my problem, going back to an older save solved it, (b) it's not a solution, his information isn't helpful once you end up in this situation and (c) I have no way of knowing if it's correct or not, since there is no way for me to tell if it would have happened again pressing the options too fast without extensive testing. His answer is incomplete and did not solve my problem. I added the information about what I did with building slowly merely as commentary, it's impossible for me to know if it made a difference. (cont.)
    – victoriah
    Dec 22, 2012 at 2:57
  • (cont..) And my answer gives the information that there's no other way to resolve it, which is useful since it warns people not to waste their time trying to build other houses.
    – victoriah
    Dec 22, 2012 at 2:59

I had this issue with my home in Morthal. It took maybe 30-45 minutes, but after using the 'disable' cheat on all of my property, and remodeling it to an entryway 16 billion times I was finally able to build a complete small house. This only happened AFTER I talked to my housecarl & made him my follower. Then sent him away.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .