I considered asking this question over at Super User, since it may be a hardware problem, but since it's specific to one game I came here.

I have the game Kerbal Space Program. It's fairly graphics-intensive, so I want to use my better graphics processor to play it. My laptop has two graphics cards inside, and when I right-click an icon on my desktop I get a context menu

Run with graphics processor -> High Performance NVIDIA processor


Integrated graphics

When I run Kerbal Space Program with "Integrated graphics", everything works alright. When I actually launch a rocket lag is a big problem; but that's to be expected. It's not the better processor.

My question is about what happens when I try to run the game with me "High Performance NVIDIA processor". When I click that from the context menu, the game loads up a white screen in the window and stays like that. It simply hangs there with a white screen indefinitely.

Now, I've tried updating my Graphics Drivers and re-installing the game, both to little effect. I was sure that it was a hardware issue until I loaded up Minecraft with both drivers, just to see a difference. With my "Integrated graphics" I was at a steady 3 frames per second, and with my "High Performance NVIDIA processor" I had a solid 30-40 frames per second.

Some details: My "High Performance NVIDIA processor" is really a GEFORCE 310M, I'm not sure what the "Integrated Graphics" is (in Device Manager -> Display adapters I have a listing for Intel(R) HD Graphics, so that might be it), and I also have a NVIDIA Cuda card. My processor is a dual-core i5 2.67 GHz (3.2ish with turbodrive), and I'm running 64-bit Windows 7 Home Premium.

This problem arose when Kerbal Space Program updated to version 0.16. Again, my apologies if this really belongs in a different place.

EDIT: Just checked with a much previous version of the game (the demo version: 0.13) and this problem is still there. I went through logs and found that I updated to Windows 7 Home Premium Service Pack 1 right around the time that 0.16 came out, so take that as you will.

  • 1
    Have you tried this with a version other than 0.16?
    – Stingervz
    Commented Nov 22, 2012 at 9:45
  • Sorry, forgot to add the version of the game. It is currently version 17.1, and this problem has been persistent with every version since 16.0. I asked in their IRC and they hadn't heard of anyone else having this problem.
    – h3half
    Commented Nov 22, 2012 at 9:49

1 Answer 1


you should choose High Performance NVIDIA processor, this is suitable with graphics device of your laptop VGA card. About integrated graphics, this software installed automatically by OS ( WIndows ) and not match driver for VGA graphics device. Don't forget to check on Device manager to ensure that graphics device driver installed correctly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .