I'm trying to install Startrek Armada 2 on Windows 7 x64. When I try to install, the popup launches and I can attempt to click install.

alt text

This briefly launches a small message box, after which nothing happens.

There are no errors in any of the application logs from this time period, and running as administrator has no effect. How can I install on Windows 7, or are they completely incompatible?

  • I am having the exact same problem except I have windows xp, I think it might be because I don't have full admin rights(Its and old laptop given to me years ago so I don't know what the story is in that regards). Would trying to install while in safe mode get around it?
    – user17274
    Dec 28, 2011 at 17:21
  • @Dav345 No idea, really a separate question.
    – C. Ross
    Dec 28, 2011 at 18:58

4 Answers 4


Wow! Haven't heard of this game in a while. If you're going to play it though, grab Fleet Operations as it brings the game up to modern standards (in graphics and gameplay). It will require your disk but it has a custom installer that works (last i checked anyway) on windows 7.

If you're sure that you want to play the game stock, open the CD manually in explorer, then go to the Setup folder and launch Setup.exe with administrator rights (i suspect you may have been launching the autorun program as administrator instead).

  • No, tried that already. I'll check out Fleet Operations though.
    – C. Ross
    Oct 25, 2010 at 11:10
  • Fleet Operations does work, and looks awesome!
    – C. Ross
    Oct 26, 2010 at 23:10
  • @C. Ross: glad i could be of help :) It's odd though, the installer seems to work just fine for me. Maybe it's because i have UAC off?
    – RCIX
    Oct 27, 2010 at 0:30

Edit: Aha! Well, I got it to work immediately: safe mode! The first thing I did was make sure that every executable in the CD-Rom drive was both set to Windows 98 Compatibility mode and set to run as administrator (verified by checking in registry). This didn't fix the issue normally, but then I booted in safe mode, ran the installer, and it worked INSTANTLY.

So, one could single out the issue by checking the processes and services that run normally but are not running a minimal boot in safe mode. And I am FAR too lazy to go through all that work. But this did seem to fix my issue. The game works fine.

I'm currently struggling with this myself--- I installed it once and it took literally a week for the installer to pop up. I uninstalled and reinstalled after messing the game up by over-modding it, and now I'm stuck in the same problem, so I'm trying to learn a bit more.

Setup*32.exe pops up for about a day, then _ISDEL.exe and another InstallShield process pops up, and then that seems to hang forever. I have no idea what was the trigger that got it to install the last time, I have UAC off and went through literally every executable and made it run through compatibility mode.

It could be an issue with having the physical disk: I have the Armada II disk scratched up beyond recognition, so I "borrowed" (ahem) an iso, and have tried both Alcohol and Daemon Tools to mount it and run... having the physical disk may be the difference, but as I said before, I got it to work ONCE after waiting literally a week without shutting down my computer or disrupting the processes.

I really hope I don't have to wait that out again. Gonna fiddle around with this and see if I can find the root of the problem.

  • Since you don't actually have an answer to this question yet, I feel like this post, or specifically the paragraph about the physical disk possibly being the cause, should be made into a comment.
    – Mana
    Feb 18, 2011 at 8:01
  • Yeah, sorry, you're right, didn't exactly know the rules for the forum. I'm editing it with my solution.
    – user7186
    Feb 18, 2011 at 8:41

Star Trek Armada 2 does not work on it's own on Windows 7 x64, as stated on the Windows 7 Compatibility Center. See RCIX's answer for a great alternative.

  • Well, what's strange is that i can run the installer (if not the game) just fine. shrugs
    – RCIX
    Nov 10, 2010 at 9:16
  • @RCIX I'd bet money you have Windows 7 x86 (32 bit). According to the Windows Compatibility page it will work there.
    – C. Ross
    Nov 10, 2010 at 12:56
  • Nope, I'm absolutely sure i have 64 bit. Otherwise the 64 bit Photoshop i have wouldn't work. :D
    – RCIX
    Nov 11, 2010 at 7:31
  • @RCIX Very strange. The installer launches for me, but when I click install it dies very shortly thereafter.
    – C. Ross
    Nov 11, 2010 at 12:23

The ONLY way I got Armada II to run on Windows 7 is using the Activision folder from a Windows XP PC.

  • Copy the entire Activision folder from the Windows XP PC's Programs folder to the Program Files (x86) folder in Windows 7.
  • Open the folder, then open the Armada II folder and find the executable.
  • Right-Click->Create a shortcut to it and place it wherever you like.

Mine is in a Gaming folder on my desktop. I'm not sure why using an XP install of the game works, but it does.

I don't recall having run it in compatibility mode because I've been using the same folder for years now and really don't remember. I recently tried but I can't get the actual Armada II game disk to even install on my Windows 7 PC.

I hope this helps someone out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .