I have been playing Minecraft for a few months with no problems. I started it up this morning, and got an error. The dark blue screen says something about a NullPointerException, the full thing can be found here. The full report in my .minecraft folder can be found here.

From my understanding, the java.lang.NullPointerException error occurs sometimes when connecting to an outdated server. However, this does not apply since Minecraft crashes immediately after the MOJANG screen. Also, note that I am running vanilla Minecraft, which is with no mods installed, which means that there are no conflicting block IDs. Any help is appreciated.

Here are my Java installations (according to Programs and Features)

  • 1
    Have you done a forced update? Commented Dec 25, 2012 at 5:01
  • 1
    Yes, I have, but to no avail.
    – user28379
    Commented Dec 25, 2012 at 13:12
  • 5
    Try deinstalling ALL Java versions you have and install the current one from here. From what I can see you are one version behind. Shouldn't pose the problem, but multiple Java versions can be a problem, if you have them.
    – Strike
    Commented Dec 25, 2012 at 14:18
  • 1
    I noticed your Java installation is slightly out of date. You could try updating it.
    – wonea
    Commented Dec 25, 2012 at 14:32
  • 1
    Why is this protected?
    – user140963
    Commented Apr 10, 2016 at 2:21

1 Answer 1


Solved it!

As said in the comments by Strike and Wonea, I uninstalled all of my Java versions. Then, I installed the latest version of Java, but that didn't work either. Then, I nuked my .minecraft folder (after backing up my saves of course) and it finally worked!

You must log in to answer this question.