I came across this disturbing problem. I have Mjoll the Lioness as a follower, and I wanted to trade some things with her. I go to the "I want to trade a few things with you" dialog, and she responds "I can carry a good bit of gear", but the inventory doesn't show up at all.

I try the console command "openactorcontainer" but still her container won't show up. I can trade with other followers and the console command works on them but not to Mjoll.

How can I make her inventory show up??

3 Answers 3


What i did is, I opened the console, clicked on Mjoll and typed 'removeallitems player'. With this, I removed all of her items and added the to my inventory (so I don't lose anything I had given her).

After that I spoke to her and told her she was naked. She immediately wore her default armor. After that I could be able to trade with her again. I don't know which part of this process solved my problem, or if it was random.

By having her stuff, she had her default armor in 5 copies (cuirass, helmet, etc etc). This is due to a bug in the game where each follower, if dismissed, and aquired again, will add the default items in his/her inventory (instead of adding just the missing ones, or the ones that there is no replacer). If you dismiss and aquire the follower 5 times, he would have his initial armor five times in his inventory.

  • To use the removeallitems you have to: 1) open the console, 2) CLICK on the NPC who's items you want to remove (so that he is the target of the command), then 3) type removeallitems ###. The ### part is the id of the NPC or player that the items will be TRANSFERED to. If you omit this part, all items from the target NPC will be removed. If you put a refId there, all items of the target NPC will be transfered to the NPC (or player) who has this id. SO, I wanted all of Mjoll's stuff to be transfered to me. Using the console, I clicked on Mjoll, and I entered removeallitems player Dec 30, 2012 at 18:03

You can use the Ultimate Follower Overhaul mod to make sure that all items that your follower has in their inventory is viewable (and removable).

It has a feature that can "convert unmovable, invisible outfit follower has to regular gear that can be removed so followers will wear whatever player places in their inventory".

I believe it works for all items, not just outfits. It is commonly used to fix the issue where the follower insists on equipping a particular weapon or wearing a particular armor, which is not viewable and removable in a follower's inventory.

A usual occurrence of this issue is the 'invisible' Hunting bow that some followers also prefer to use, despite being given a better bow. The Unofficial Skyrim Patch (USKP) fixes that issue.

All followers will no longer have invisible Hunting Bows that can't be removed from them that they would use even in preference to much better bows they were given; they will now be visible and can be removed from the follower normally

Full USKP changelog

  • I am not sure if the hunting bow issue has been fixed. I already use all the three unofficial Skyrim Patches (the main one, with the ones for dawngard and hearthfire), and the Unlimited Follower Overhaul. I had married Mjoll and parted ways with her before I had activate all those mods and patches though. I have been partner with Serana from Dawnguard. Since i hated having only one follower, I installed UFO and the unoficial patches, and after that I re-reqruited Mjoll, who also happen to be my wife. Maybe the problem existed before the patches, and it just wasn't fixed. Dec 30, 2012 at 17:53
  • But my problem here, was NOT Mjoll's stuff. My problem was that I couldn't get her to even OPEN her inventory to me, to be able to trade with her. Even using the console with the command "openactorcontainer" on her, could not open the inventory. Seemed like a bug to me. I could do it with everyone else, but not with her. It happened that the problem solved "accidentaly" after I was playing around with console commands and I don't really remember what I did. I posted my solution as an answer though, here. Dec 30, 2012 at 17:56
  • @Saysmaster I see. I initially thought that her inventory opens up, but her items do not appear. Dec 31, 2012 at 4:24

I had the same problem and I managed to fix it (with a whole butt load of work.) I figure that the inventory only opens once appropriate dialogue has been audibly spoken, meaning that subtitles don't count. By appropriate dialogue I mean the words followers say when you ask to trade with them like the infamous "I am sworn to carry you burdens."

If you have any mod that messes with follower dialogue then that might be the culprit. All it took for me was an uninstall and the problem was solved (after 3 days of torture.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .