4

I deliberately entered a river in order to cross it. I used Alt+direction and my adventurer began swimming around the river. But now I can't climb out, on neither of the two shores.

Is there a different key combination to climb out?

6

Are you at least a novince swimmer? Because if you're not

Dabbling or untrained swimmers will start drowning immediately upon contact with water, and require a ramp or stairway to get out. If neither are accessible, they're done for. (Emphasis Mine)

If you are, you should be able to alt-move above.

To get out, alt-move carefully against a shoreline and select the option to move above.

From: Dwarf Fortress Wiki: DF2010:Swimmer

  • 1
    Yes, I am a novice swimmer. Whenever I tried to alt-move against the shore, nothing happened. If I alt-moved somewhere into the river it worked, but it didn't work if I moved into the shore. Luckily I got out because the river turned into a brook farther up. Maybe it was a bug. – R. Martinho Fernandes Oct 26 '10 at 23:37
  • @Martinho Bugs happen. – C. Ross Oct 27 '10 at 0:03
0

It may well be that the river is in a 1 block high canyon, so you swim to the side but it's a (small) cliff rather than a shore. If that's the case then I think you're SOL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.