I have two Xbox 360's, one WiFi and the other wired through the same Linksys E3000 router with DD-WRT (v24-sp2 (04/13/11) std-usb-nas firmware).

Mine (the wired one, though hers has been wired in the past and it didn't appear to help) always seems to be open (green), and hers is either moderate or closed (oj/red)

Even with the original router firmware I've never been able to get both consoles into "open nat" mode, and it makes playing certain games together almost impossible for me and my wife because we can't seem to get into the same game.

I have uPnP enabled and the DMZ disabled, and some minor port forwarding to allow for a Minecraft server (Ports 25565 and 25566 for a testing copy of the server), but other than that the settings are mainly at their default, on the xbox's and the router.

Are there any settings I can configure to allow this to work properly?

  • 1
    This article seems to mean that this is only possible with a router that supports Static DHCP and/or DHCP Reservation. I would post it as an answer except that I don't have any way to test it, and the article's "do it yourself because I won't explain every detail" means I can't properly summarise the process without a testing rig. Anyway, this might help, or help someone write a full answer: techknowlogy.jigsy.com/entries/general/… Dec 29, 2012 at 2:05
  • Well, I tried it, and it was a very long article that describes basic DHCP reservations. That and checking on uPnP for the hundredth time doesn't seem to have fixed it, but at least we're at a stable orange/green nat
    – Jane Panda
    Dec 30, 2012 at 17:05

4 Answers 4


To avoid some confusion for future readers, this is what at least got me to two "moderate" NAT's on the 360's, which is good enough to find games together:

  1. Use DHCP on both 360's
  2. Specify hostnames for both 360's (in the advanced tab in network settings)
  3. In DD-WRT, assign reserved/static IPs for the MAC+hostname of those 360's outside of your DHCP range

Occasionally somehow we end up with red NAT again, and I turn off both 360's, clear the uPnP table in DD-wrt, and turn on the one who had red NAT first, then turn the other one on 20 seconds later...

It's not a permanent fix, but it seems to work decently.


You should be able to get Open NAT on multiple Xboxes as long as your router has a good implementation of UPnP. Microsoft used to have an Xbox LIVE compatible hardware list (archive link) which said:

All of the network hardware in the following lists works with multiple Xbox 360 consoles connected at the same time.

Although not being on the list doesn't necessarily mean your router won't work. Obviously MS is testing with OEM firmware. I don't know how good DD-WRT's UPnP is - you could perhaps try OpenWRT.

To recap, you should configure your router:

  • DMZ off
  • port triggering off
  • no Xbox-specific ports forwarded
  • UPnP on
  • DHCP server on - you don't need address reservation
  • NAT enabled obviously (if it's even optional on your router)

Configure the Xboxes:

  • IP Settings: automatic
  • it might help to give each Xbox a (different) Host Name under Additional Settings; I don't know what protocol this setting affects, and the xbox website isn't telling me.

This answer was originally posted for a question that is probably a duplicate of this one:

Usually, port forwarding issues on the 360 are solved by forwarding ports to a specific IP address. I can tell you from prior research on this topic that you can't forward ports to multiple IP addresses with one router.

The easiest thing to do would be to forward the appropriate ports to one box, and then put the other box in the DMZ. The DMZ puts the box outside the firewall, which is a security risk. That being said, I've had a 360 in the DMZ for years at a time without any issues. This is the current setup I'm using with my Xbox 360 in the DMZ, and my Xbox One with forwarded ports.

Another possible approach would be to get a 2nd router, forward the ports to that router, and put both boxes on the 2nd router. I haven't been able to get this to work myself, but I'm told it should be possible. This would be more secure, if you can get it to work.

  • I'm not sure the second router thing would work; once the traffic hits the router you're into that router's NAT and back to square one.
    – Jane Panda
    Dec 8, 2016 at 4:08
  • @Bob Like I said, I haven't got it to work. I expect you would want to disable the NAT on the second router. The other solution with ports and DMZ definitely works, though.
    – DCShannon
    Dec 8, 2016 at 18:13

First off, connect to your router, which will normally show up as your default gateway if you run ipconfig on your computer. Then set your router settings to:

DMZ off
port triggering off
no Xbox-specific ports forwarded
UPnP on
DHCP server on - you don't need address reservation
NAT enabled (if it's even optional on your router)

(copy paste from above, he had the right idea just didn't tell you how too get to your router)

  • That is not the usual default gateway, that is your own Internet provider's gateway. It won't work for almost anyone else. Jun 30, 2013 at 20:20
  • @SevenSidedDie Are you sure? We are talking about a router here. So a computer connected to a router would have that router's IP as its default gateway. This also applies to modem-routers too. Pure modems are actually quite rare nowadays. Jun 30, 2013 at 21:05
  • @deutschZuid I'm not sure I follow your reasoning, but I am certain that the (now removed) IP address is allocated to a specific geographical IP authority and virtually no-one reading this can usefully copy-paste it in order to access their local router's configuration settings. Jun 30, 2013 at 21:38
  • @SevenSidedDie Ah.. I didn't realize he had a weird IP there. The default gateway address on the PC should belong to a private address range. I have no idea where he got that IP from. In any case, it should've been if anything. Could well have been a typo by the author judging by the atrocious misspelling streak. Jun 30, 2013 at 21:44
  • is not an existing IP anyway whatismyipaddress.com/ip/ So I am 99% sure that was a typo. It has nothing to do with the guy's ISP gateway. Jun 30, 2013 at 21:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .