I had Kinect Fun Labs and many of its mini-games installed on my XBox prior to the initial Metro/Tiles dashboard update of around a year ago. Now, after the latest dashboard update the files are still on my Xbox's hard drive (they show in Settings -> System -> Storage -> Games and Apps). But I can't find where to access/run it.

There is a Kinect Central tile on the Dashboard's Home screen, but there doesn't appear to be any launcher for Fun Labs in there. It doesn't show up in the My Games list, or the My Apps list. Fun Labs can still be installed from this page on xbox.com Kinect Fun Labs but it shows as an add-on (it has the gamepad with a plus "+" sign over it), with no sign of which game or app it is an add-on to, the description also shows that its only 18months old (released 06/2011) I can't believe that an app would be so totally out of support already as to be inaccessible.

I've tried deleting it and redownloading (from the link above) but that doesn't seem to make any difference either.

Some of the mini-games in there were quite fun and I was hoping to play them with some young relatives who'd visited lately.

Failing the above, is there any way to access the mini-games that were formerly hosted in Kinect Fun Labs, eg Googly Eyes, Bobble Head, Kinect Me, Build A Buddy, etc?

  • If you have young ones who want to play with the Kinect, I highly suggest you grab Happy Action Theater and/or its "sequel" Kinect Party. (Kinect Party is currently free, I believe...)
    – agent86
    Dec 30, 2012 at 17:56

3 Answers 3


The marketplace lists Kinect Fun Labs as an addon to the game Kinect Fun Labs, and you'll just recurse infinitely if you try to do anything from this page but download the addon. The only way I was able to get into Kinect Fun Labs with the latest dashboard update was to:

  1. Press the Guide button (the "Xbox button" in the center of the controller)
  2. Scroll all the way left to the "Games and Apps" slice
  3. Select "Recent"
  4. Press the Right Bumper (RB) twice to get to the "All" tab
  5. Scroll down the list to Kinect Fun Labs and hit A

Owing to the odd way it's classified by the Marketplace, you can't pin the game, and it doesn't appear to show up in the "Recent" view even if it is the last thing you've played. You'll have to repeat this process each time you want to launch the Labs.

  • Thanks, it's a bit cumbersome but that appears to have got me in!
    – GAThrawn
    Dec 30, 2012 at 19:29
  • @GAThrawn, yeah, I wish there was an easier way, but there doesn't appear to be...
    – agent86
    Dec 30, 2012 at 20:46

Have you tried searching for Kinect Fun Labs? If you go to the screen one to the left of Home ("Bing"), and enter Kinect Fun Labs, that should bring up the game page for it. Assuming you have it installed, there should be an option to play it from there (this works with other games, at least).

In theory, you should be able to Pin it from there as well, so that could make it easier to access in the future.

  • 2
    If you do this, you end up at the Marketplace page for Kinect Fun Labs, which doesn't appear to let you actually launch the game, sadly.
    – agent86
    Dec 30, 2012 at 18:20

This works also: just hit download again. Then the option to play now will be there. I did that in August 2013.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .