The game crashes all the time. It just stops responding and I have to Ctrl+Alt+Del out every single time I load the game after like 10 minutes of gameplay. The window closes and then steam says the application was already running then it looks like the game is updating for like 2 seconds.

I have looked up countless solutions. I've tried reinstalling, I've updated my graphics drivers, my sound drivers, I've verified the cache on steam, I disabled automatic updates, I turned off multisampling, turned on V-Sync. It's ridiculous how bad this game is in terms of actually working. I had an easier time getting the original Thief to work than I have this game.


  • Windows 7 64-bit
  • Intel Core i7 2600K
  • GeForce GTX 560
  • 310.64 WHQL graphics drivers
  • For information about this part "then it looks like the game is updating for like 2 seconds": F1 2012 uses Steam cloud, so when Steam sees that the game is closed, it synchronizes your saves. This is what looks like a quick updating.
    – Gnoupi
    Commented Jan 3, 2013 at 15:35
  • Would that cause a problem with the game? I tried turning it off and it didn't help. It also seems like it's getting progressively worse. Like when I first bought the game, I bought the 2-pack so I could play with my friend and I could get through the multiplayer menus and start a game but it would freeze after like 2 laps. Then I tried doing the young driver test and I couldn't get past the menu. Now it's freezing like 5 seconds after I open the game.
    – Koha
    Commented Jan 3, 2013 at 16:00
  • no, not really. About your issue, I assume you checked for overheating problems, and/or tried to find some game logs? (note that I don't know the game, I'm just throwing general suggestions)
    – Gnoupi
    Commented Jan 3, 2013 at 16:48
  • Yeah I checked temperatures, my CPU was at ~55c and my graphics card was at ~60c. I also can't find any logs and when look up where I could find them, it just comes up with reviews or real F1 footage. I also tried setting the f1_2012.exe to run as an administrator and in Windows XP SP1 compatibility. Which made the game last 6 minutes, oh boy.
    – Koha
    Commented Jan 3, 2013 at 17:31

1 Answer 1


I found the problem. I had contacted Codemasters through E-mail since their support forms on their website wouldn't work for me. It took like 3 days for them to find the problem and 4 responses later they told me to disable my sound card, and it worked.

So I thought maybe it wad something with my sound drivers since I had a kind of hard time finding some. I looked harder than I did the first time and saw that there were new ones. I have the Realtek ALC892 chipset on an Asus P8Z68 motherboard. I downloaded the drivers from here: http://www.realtek.cz/realtek-download.php?realtek=ALC892&system=3

So I enabled my sound card again after installing the drivers and haven't had any problems yet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .