I've been having issues with the Steam Overlay while playing The Witcher recently. I suspect that the issues are specific to the fact that the game was (somewhat sloppily) ported to Mac OS X with a quick Wineskin wrapper - a theory supported by this question. Specifically, the Overlay appears when I hit Shift-Tab (most of the time. Sometimes it's totally non-responsive until I restart the game), but it's completely non-interactive. The cursor remains as the games custom cursor, and I can still interact with the game behind the overlay. I cannot however, click on anything on the overlay.

Is there anything I can do to fix the overlay to make it usable?

  • Are you running it on OS/x? Might be worth mentioning in the question :)
    – Neon1024
    Jan 8, 2013 at 9:20
  • Overlay does not work for The Witcher and Witcher 2.
    – user28015
    Jan 8, 2013 at 9:54
  • @DavidYell I did mention it in the question. Also, it's OS X. Not OS/x - that nomenclature is for an old persnickity IBM thing that only ever really caught on for ATMs. (Pet peeve, sorry. See also: 'MAC'). Jan 8, 2013 at 12:03
  • 1
    @LessPop_MoreFizz I saw you mention the game was ported, but not a mention of what platform you were playing it on. IBM's system was OS/2 Warp, similar but not the same :)
    – Neon1024
    Jan 8, 2013 at 13:56

2 Answers 2


The Witcher is simply put a horrible "port" that doesn't deserve the name "port".

You could try upgrading the version of Wine it runs on: http://www.insidemacgames.com/forum/index.php?showtopic=43407#entry409385

Now to get technical: The Steam Overlay for Mac is simply a slightly modified and recompiled version of the Windows Overlay. The Overlay tries to detect whether to use a DirectX hook or an OpenGL hook (since both coexist on Windows). The Overlay in this case chooses DirectX, will properly inject but then rely on Windows APIs which are obviously not available, leading to a malfunctioning overlay.

Since you can't tell the overlay what API to hook (Valves detection algorithm does that), this is an issue without a solution you can apply. Whoever ported the game, should take responsibility for this mess and clean it up.


In the Steam Library, right-click on the game in question and open up it's Properties window. Under the "General" tab, ensure that the "Enable Steam Community In-Game" box is checked. It should be checked by default; however, there are certain situations where it's better to have it disabled - in some games you can eke a few more frames-per-second out of your GPU by turning it off.

  • 2
    The overlay appears, so everything is set properly. It's just not interactive. I realize I failed to mention this however. Jan 8, 2013 at 12:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .