15

In my Dishonored playthrough on PC, I just completed the Flooded District mission and, of course, I went to retrieve Corvo's equipment.

I succeeded and for a while I could still use every weapon I had. When I switched to Blink for my left hand, everything disappeared again from the shortcut bar, leaving me with the gun on 5 and the rest of the spells from 6 to 0. Weird thing is that I still can see the all my retrieved equipment inside my inventory.

I tried to restart the game a couple of times, completed the mission and started the next one right away to see if it would fix, but I still can use only the blade and the gun (with my powers).

I can't seem to find anything around (patches nor articles), can somebody explain what's going on please? Does it relate to my max chaos playstyle?

UPDATE Yesterday I did beat the game and start a new one at max difficulty level. Still no equipment :-/ I plan to play it low chaos and try to beat it again without any homicide, so it's fine. But still, it's a bit of a bug .

UPDATE #2 I forgot to mention: I can't interact with my equipment inside my inventory (can't use items or can't equip them) no matter what I try.

4 Answers 4

2

Sounds like the game was not installed correctly. Your best chance is to reinstall the game.

1
  • 1
    Why the downvotes? While not the best answer in terms of SO Answers, this still might help.
    – Asunez
    Commented Jan 8, 2016 at 8:18
0

I'm not entirely sure if I understand but it sound like all your shortcut mappings have disappeared. You can see the equipment in your inventory so that's good - it's not like your game suddenly decided you didn't have any weapons!

Hold down the middle mouse button* and it will open up your equipment wheel. From there you can move the mouse to highlight different items and press your 1-0 keys to assign them.

* or if you don't have one, check the control mappings to see what is assigned

1
  • no can do :( I can't use my items nor equip them, tried everything so far :( Commented Feb 1, 2013 at 9:44
0

Re-install the game or verify game integrity of game cache in steam. To verify integrity of game cache use this guide https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

-2

You need to equip the weapons. Hold down middle mouse button, this will bring up the radial menu.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .