All crit boost effects (kritzkrieg, crit-a-cola, frontier justice) in TF2 generate a very fancy particle effect applied on the weapon that's getting the boost. If you don't know what I'm talking about, here's a pic of the effect in action:
Crit boost particle effect

While it looks OK in this pic, I find it gets distracting added to the dozens of other particle effects you get in an average pub game, especially with the Frontier Justice (since it stays on indefinitely). More importantly though, it ends up being a CPU hog. My framerates drop significantly while I'm getting a crit boost, which is irritating since that's when you need the most precision.

My question is: How can I disable this visual effect?
I know that TF2 is highly customizable, I've installed tons of HUDs and skin mods, but I can't find anything on this subject. I think it's possible, cause you sometimes see customized explosion effects on frag videos.

Ideally, the weapon would just turn blue (or red) instead of getting all shinny. So I would still know the effect was there, but it wouldn't be so CPU intensive.

  • 2
    Trying to what? Don't keep us in suspense! Oct 29, 2010 at 4:25
  • Oops! My bad. Was gonna say something there, but changed my mind.
    – Malabarba
    Oct 29, 2010 at 5:30

2 Answers 2


From two helpful people on the Steam forum, here is a list of particle removals and optimisations.

You probably want 'Direct X 9 crit boost file by itself', unless you know you're running DirectX 8 (usually in conjunction with a config). I think that it still removes the halo effect though.

  • Seems to be exactly exactly what I"m looking for. Very helpful indeed!
    – Malabarba
    Oct 29, 2010 at 13:22
  • @malabarba Did it end up working?
    – The Man
    Apr 25, 2015 at 4:30

For a more extreme solution, put the following code in your autoexec.cfg:

bindtoggle "r" "r_drawviewmodel"

This will allow you to press the r key at any time to turn your weapon model off completely. Press the same key again to turn it back on. You may replace the first instance of "r" (not the one at the beginning of r_drawviewmodel) in the code if you want to bind this ability to another key.

  • 1
    Note: In case it's not obvious, you can also just enter this in the command console (which should be able to be bound to a key itself (I prefer to bind it to ~ for convenience)), and obviously it will disable the ENTIRE view model, so if you don't want that, don't do this.
    – Zibbobz
    Apr 7, 2014 at 16:40
  • 1
    @Zibbobz You are correct that it can be entered in the console, but you would have to type it every time you booted the game. I find it more convenient to place the code in autoexec.cfg and forget about it. Apr 7, 2014 at 18:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .