6

So to unlock Mods on your Mac version of Civ V, you need to comment out line 33 of MainMenu.lua. When Gods and Kings came out, MainMenu.lua moved, but the fix still worked. Now that "Brave New World" is out, it appears MainMenu.lua has moved again or has just been removed entirely.

Where's MainMenu.lua so that I can perform some surgery on it?

3

On my Mac, it's at the following location:

  1. Find the Civ 5 app (~/Library/Application Support/Steam/SteamApps/common/Sid Meier's Civilization V/Civilization 5.app).
  2. Right click the app, and select Show Package Contents.
  3. Navigate to the following folder: Contents/Home/assets/UI/FrontEnd
  4. MainMenu.Lua is in that folder. Looks like the line to comment out is 40 now.

(I haven't tested this, but I've enabled mods before, and this file looks very similar to the old version.)

  • Awesome, looks like it worked. Now to actually put mods in whatever folder they have to be in so I can enable them… ;) – Josh Roby Jul 12 '13 at 21:26
  • 1
    Alternately just open the Finder, hit ⌘G and paste in ~/Library/Application Support/Steam/SteamApps/common/Sid Meier's Civilization V/Civilization 5.app/Contents/Home/assets/UI/FrontEnd and you will go right to the folder if you used the standard Steam install. – CyberSkull Jul 13 '13 at 4:55
-1

IT causes that you dont change hidden files to unhidden files, please follow this link to change hidden file to unhidden files>.."

" I hop it works to you ...

  • Please summarize the instructions in the video. That way, if it ever gets removed, your answer is still valid. – Frank Oct 19 '14 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.