1

For a few weeks ago i created a minecraft server and started playing vanilla with my friends, and we had fun, still have fun but we want to move on to a bukkit server. So i downloaded the latest craftbukkit, followed the instructions e.t.c. My .bat works, but the problem is: I can't connect to my server. i have tried localhost, my own ip and all i get is a logging in screen going on forever. Please help.

Server Properties:

#Minecraft server properties
#Fri Jul 04 19:01:58 CEST 2014
generator-settings=
allow-nether=true
level-name=world
enable-query=false
allow-flight=false
server-port=25565
level-type=DEFAULT
enable-rcon=false
force-gamemode=false
level-seed=
server-ip=25.190.93.55
max-build-height=256
spawn-npcs=true
white-list=false
spawn-animals=true
hardcore=false
snooper-enabled=true
texture-pack=
online-mode=true
pvp=true
difficulty=1
gamemode=0
player-idle-timeout=0
max-players=20
spawn-monsters=true
generate-structures=true
view-distance=10
motd=A Minecraft Server

And yes, minecraft is allowed in the firewall.

  • Are the ports forwarded? – eyeofthehawks Jul 4 '14 at 18:26
  • 2
    Also, try deleting the IP from server-ip entry, leave it just blank. – Little Helper Jul 4 '14 at 18:31
1

Always leave server-ip blank unless you're doing something unusual and you understand what "IP binding" means and you know that you need Minecraft to do it.

That IP address you have there is your external IP address. (I checked.) However, your actual Minecraft server machine does not own that IP address because it's behind a router on a local network (LAN) and owns a completely different, "local only" IP address assigned to it by the router.

What setting server-ip to your external IP address has effectively done is told Minecraft to ignore all connections to all addresses except that one. But since your server machine doesn't actually ever see that external IP address (remember, it's real IP address is a different, local-only one provided by the router), that means it ignores all incoming connections.

So blank server-ip and you'll be able to connect.

0

I would give a shot and remove the IP in "server-ip=" and try to use 127.0.0.1, if that doesn't work, go into cmd and type "ipconfig" - find your local IP address & try and put that in.

  • 3
    localhost is equivalent to 127.0.0.1 – eyeofthehawks Jul 4 '14 at 18:26
  • 1
    I am aware of that, however I've seen in the past where either the user has deleted his host config (where localhost routes to 127.0.0.1) or for some reason localhost didn't work and 127.0.0.1 did. – user1622951 Jul 4 '14 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.