I've just acquired the Archangel armor in XCOM: Enemy Within and I'm not able to ascend when in Flight Mode. I activate Flight Mode, my sniper levitates slightly off the ground, but I'm not able to find ANY way to make myself ascend levels at all like you see at the beginning of this YouTube video.

I'm not getting the movement indicator box above my soldier at all when hitting the key I've mapped to Ascend Floor. The screen shifts but no indicator box.

I'm playing using a trackpad on OS X, playing the Steam version of the game. I've tried plugging a mouse in to use the mousewheel for Ascend but no effect.


I made a quick screen recording of what I'm experiencing. You can see that I'm activating Flight Mode and then both scrolling the mouse wheel (which is bound to Ascend/Descend) and using the on-screen buttons. When I've "Ascended" there's no movement indicator to show I'm flying up, but when I click around on the map you can see that the movement indicator that stays along the ground is no longer aligned to where I'm clicking.

  • I don't know the game, but maybe something useful here? gaming.stackexchange.com/questions/127650/… – Kevin Reid Jul 6 '14 at 21:01
  • Yes, see Alex's answer to that question for the issue. I think you are activating flight mode but not actually moving vertically. The secondary problem is identifying which keys you need to press with your particular keymapping. – walrus helmet Jul 6 '14 at 21:03
  • Nope, I'm activating flight mode and then pressing the key mapped to Ascend but nothing's happening. I've tried remapping keys, mapping the function to the mouse scroll wheel, quitting/relaunching, even reinstalling. I should note that I've played the game on the Xbox 360 before so I'm familiar with how the flight mechanic works, it just appears broken on my installation. – Scott Jul 6 '14 at 21:12
  • I've also used the clickable on-screen Ascend/Descend Floor controls to no effect. – Scott Jul 6 '14 at 21:20
  • 1
    I may be wrong, but from watching your first video it appears that the user might be clicking and holding on the unit and then ascending/descending. – Xantec Jul 8 '14 at 18:32

It's a bug. I contacted Firaxis support and it looks like this is a bug in either my install or computer setup. The exact cause is still being tracked down, but in a save file I sent to them they were able to fly using the Archangel armor with no problems. When I followed their instructions I got nothing, however.

I'm going to try installing my Steam version on another computer (or a Windows install in Boot Camp on my Mac if I can snag a Windows install disc from the office) and see what happens. Will report back if I'm able to do so!

| improve this answer | |
  • 1
    They actually tried your save file to reproduce the issue? That's actually some decent support for a video game. Good luck on getting it working, Archangel armor is a very handy tool in the last half of the game. – user973 Jul 10 '14 at 13:49
  • 1
    Yeah, I've been really pleasantly surprised at the quality of support from Firaxis. I've been dealing with the same guy the entire time and he's been incredibly helpful. Haven't tracked down the issue yet so he's now put me in touch with their QA department even. – Scott Jul 10 '14 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.