3

Last weekend I bought Red Alert 3 on steam with the intention to play it with a friend. I know the official servers are down, but it should be possible to play it via hamachi or other lan software.

However when my friend boots up the game, his network seems to crash. He is no longer connected to hamachi, steam, teamspeak or the internet. From the moment he closes RA3, his network is fine again. Most of the time he is still online for a few seconds, but after that everything online is dead.

I've already tried a lot and I'm currently out of ideas and getting no response on the EA support forum.

I've opened UDP ports on the router and forwarded them to the pc. I've disabled firewalls and temporarily enabled DMZ. Also tried to start the game withouth hamachi and teamspeak and no result.

The game always starts up and after a minute the networkconnection is dead. On my side I don't have any problems.

I'm thinking that something conflicts in the network when the game is booted. But I don't have any idea what it could be.

Update

Things I tried

  • Updating network drivers
  • Checking event log for errors (didn't see any)
  • Enable DMZ
  • Opening udp ports on router
  • Disabling windows firewall and AVG
  • Booting the game without other programs such as hamachi and teamspeak

Update 2

It seems to be a thing with EA Games. My friend installed Spore and when Spore is launched the same issue occurs and network connectivity dissapears. Strangely enough when we alt+tab out of the game, network is back (but the game is still running in the background). Alt+tab back in the game, poof network is gone.

2

If the game is crashing the network, it is possible that the drivers are out of date OR the software used in the game is conflicting with his native drivers and causing a crash. My PC crashes a certain program whenever I plug my headphones in, as an example.

Things to try would include:

  • Updating drivers for the networking device = check the manufacturers website
  • Refreshing the Steam install (Verifying the game files)
  • Trying a different network adapter (ie, a wireless adapter, if possible), and disable the cabled adapter during the test
  • Check the Event Viewer to see if a certain program is causing the crash, or a certain service affected. If it is a service, force it to re-enable every time after a crash to see if that is a workaround for it (open services.msc, right click on the service, select properties, click on the recovery tab, and change all the drop down boxes at the top to "restart the service", although the 1 minute delay may be too much for it)

Unfortunately, there is no one-stop shop answer to solve this, just some testing. Good luck

  • drivers update, files verified and don't see errors in the event log :( – Stephan Celis Dec 6 '14 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.