In the first mission, you are given a heartbleed.vspam. However, thinking it was an against-me virus - I deleted it.

Now, there's no way to get another copy, as the Downloads Center does not have a download button, despite having the virus uploaded on it.

I've searched the forums, where some people waited for the server to reset its software, but every time it reseted it software (and hardware), I cannot download a new copy. How do I complete the starter mission?

The furthest I've got was up to the stage of uploading the virus, after cracking the password... Except I don't have a virus to upload in the first place.

2 Answers 2


Have you tried getting onto the first puzzle server ( It also contains a copy of heartbleed.

Make sure to delete your logs.

UPDATE: When you are logged in an NPC server, you can see the hardware reset timer and the software reset timer. Try to log in/refresh the server software list when the software reset just happened. If it doesn't work, you'll have to wait for the hardware reset.

enter image description here

  • 1
    I've tried uploading the copies found on the first puzzle server and download server, but it doesn't trigger the mission to complete.
    – aytimothy
    Dec 11, 2014 at 6:17
  • 1
    I updated my answer with the NPC Servers reset timers. Try to go on the server when it just reset (hardware reset ensure the original software files are not hidden, since the software reset will only put the files back if they were deleted AND the server has enough disk space).
    – Jeff Noel
    Dec 11, 2014 at 13:52

This is incorrect.

Trust me from experience. The issue is that the heartbleed virus the tutorial gives you has a very specific software ID, the ID can be seen in the URL when you go to run heartbleed or upload it.



Notice the "id=173743"

Notably also the heartbleed from the download center does not even turn red. (The tutorial highlights the next recommended action in red) This is because it is not the same software ID as the heartbleed the NPC gave you.

  • What is incorrect?
    – Joachim
    Jan 18, 2020 at 19:37
  • The OP states " In the first mission, you are given a heartbleed.vspam. However.... - I deleted it. " And this is my exact problem. The suggested resolution is to wait for the NPC timer to reset to get another copy. Getting another copy does not allow you to complete the tutorial because the new copy is not a copy at all but an entirely new software with the newest software ID. The tutorial mission is waiting for you to upload the specific software ID. - In other words you solved the missing virus problem, but did not solve the unable to complete mission problem. Downvote me but you are wrong
    – 0xKate
    Jan 30, 2020 at 5:56
  • If you dont believe me go look at hackerwars.io its a source code copy of hacker experence legacy. Go make a new account and when the tutorial gives you heartbleed.vspam delete it before completing the tutorial and share how you got out of the situation, that is if you even can. You are only leading to an increase of misinformation on the internet by blindly down-voting people.
    – 0xKate
    Jan 30, 2020 at 6:03
  • So this is a reaction to the credibility of the question? It's usually better to address issues like these in comments, and ask for specification from the OP. I realize you don't have enough reputation to post comments, so you'll just have to wait until you do. Nevertheless, the other answer is accepted, so it apparently worked for the OP.
    – Joachim
    Jan 30, 2020 at 9:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .