I've started a new character in Guild Wars 2. Occasionally, at seemingly random times, it will say something like "A little help here" or "Never waste a corpse". Just speaking out loud to itself, it seems.

Is there a way to get the character to stop speaking?


This is actually a bug in the latest patch. Your character's lips will move, and it will sound like it is coming from your character, but it is actually caused by other characters on the map.

These bits of dialogue are normally triggered by your character gaining a boon, gaining a condition, becoming downed, being revived, using a shout, gaining a level, uncovering a new part of the map, or other changes to your character's state.

This is a known issue, and will likely be fixed soon. In the meantime, you can go to Options (F11) -> Audio (third tab) -> Dialog Volume, and move that slider all the way to the left. Note that this will mute all speech, not just that of your own character.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.