9

I recently got an old NES, the problem is I have yet to get a game to work. I know the games I have do work they've been tested in a friends NES.

I've taken it apart, cleaned the contacts on the motherboard (although its still kind of dirty some of its impossible to get off), taken out the 72 pin connector and looked at it. Its not the prettiest I've seen but its fairly clean and the pins are not bent down they are all pushed up and tight. I know the pins aren't the issue because i tried a friends in mine (his 72 pin connector is in beautiful condition) and still did not work.

We even tried the boiling thing with mine and although it actually got a lot of dirt and grim out still nothing.

Without a game in the light flashes red and the TV displays a grey screen that flashes with the light. With a game in it does the exact same thing. Literally NOTHING changes. Could this be a problem with my lockout chip? Do I need to disable it? And if so before I do are there any risks or downsides to disabling it?

Update - Disabled lockout chip. Chip stopped resetting the console but still couldn't get any games to play

1

You might have a dead system.. :\ The only other thing I can think of is to check the contacts that connect the 72 pin connector to the motherboard. Maybe they've corroded. Try cleaning that with some alcohol. (I use 70% on my cartridges) Maybe that would work.

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.