2

I am trying to join a family member's world. We are both on PCs, one Windows 8.1 and one Windows 7. We both use Minecraft 1.8.8

My family member's PC firewall is open to Jave SE binary and to Minecraft on the Public network, which is how the household WiFi router is set up. My firewall is also open to same (Java, Minecraft), and network is also public.

My family member enters their local world, and opens it to LAN, so "Local game hosted on port 5xxxx" appears in chat. I open Minecraft, click Play Multiplayer, and it scans forever on my local network (we don't have an actual LAN, just share a WiFi router). So I do Direct Connect and enter IP:Port, where IP is from doing "ipconfig" on the hosting PC and using the IPv4 local IP (192.168.x.xx), and Port is the 5xxxx mentioned above.

When I join I get the following error:

java.net.ConnectException: Connection timed out:no further information:

Note that I can go to cmd window and ping either her local IP (192.168.x.x) or the external IP (found via WhatsMyIP.com) for her machine, and the ping yields an apparent success ("Reply from ...").

What else can I try to enable me to connect to the other computer?

  • 1
    Did you do this? Just opening a world doesn't allow LAN connections by default. – dly Oct 6 '15 at 6:45
  • @dly Based on their description, they used the 'Open to LAN' function rather than the new server function. Also, their extensive troubleshooting shows that they do know what they're doing. – angussidney Oct 6 '15 at 8:45
  • @YoYo Based on your description, you have tried everything that should be tried. I suggest rebooting both your computers and your WiFi and trying again. If that fails, try connecting the other way around: you can be the host and she can connect. If it is a specific world you require to play on, you can always copy it to the other computer. – angussidney Oct 6 '15 at 8:51
  • I still believe it's the firewall. – dly Oct 6 '15 at 9:00
1

Response

There are multiple complicated reasons for this, so, let me give you a few likely solutions instead of explaining.


1. Completely disable any other Firewalls you may have installed (Norton, Avira, Bitdefender, etc.).

2. This one requires a bit of trial and error. Check Windows Firewall, and make sure Javaw.exe, Java.exe, is allowed through. First, enable home, test it, disable home, test it, enable public, test it, and enable both, test it.

3. If your network reads Public, or shows a image of a bench, change your network to Home network. If it reads Home, or shows a picture of a house, do the opposite. After this, repeat step 2.

I hope I helped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.