When I run FTL in full screen mode, I can't alt tab back to the desktop (Despite the game having a dedicated auto-pause for when the window looses focus, very curious).

I've relaunched FTL with every full screen option (Stretch, Borders, Native) and none of them let the window manager switch focuses.

None work, although in native I can see my desktop environment's panel drawn over the game window, but cannot be interacted with.


Option: Manually set windowed resolution

The game's windowed-mode loads its display resolution from an ini file located here


This file has a small section for manual display size, here is the original and my settings for a thin window manager on a 1920x1080 dispaly.

Original Text:

#Manual resolution choices - overrides anything in the options
#Set manual to 1 and then change the resolution
#Does not check if values are valid. Use with caution.
#If you do not support GL_ARB_framebuffer_object, "stretched" will not function

My Config (Cinnamon WM + Numix Window Borders 1080x1920 Display):

#Manual resolution choices - overrides anything in the options

The summary of the problem as I understand it, FTL uses SDL (Simple DirectMedia Layer), for both receiving keyboard events, and drawing a desktop window. From what I understand, its a limitation (really out of scope) for SDL to integrate with a window manager (I suppose you could even write a window manager with SDL!). A bit unrelated, but one topic asking how to handle ALT+Tab in SDL suggests forfeiting SDL Altogether and using the GTK desktop-programming toolkit instead, which is a lot of hard work [and not necessarily a very practical work] to get alt tab support and other minor desktop integrations.

External Links

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.