1

I'm creating an adventure map and need a dialogue system for the NPCs. One simple way I thought of doing this was having a chain of click events in the chat. Unfortunately I'm still new at commands and all the ones I tried either didn't work or gave a result that I wasn't fond of...

Here is the command I tried:

tellraw @p [{"text":"text","color":"green"},{"text":"text","color":"aqua","clickEvent":{"action":"run_command","value":"/say @p"}},{"text":" Click to Continue","clickEvent":{"action":"run_command","value":"/tellraw @p text","color":"aqua"},{"clickEvent":{"action":"run_command","value":"/text"}}]
1

You appear to be using a generator, as it looks like you didn't fill out a few of the boxes. If not, you should be using one, as it makes this far easier.

At the very end of your tellraw: {"clickEvent":{"action":"run_command","value":"/text"}} the command you're trying to run on click is /text which is not a command. This shouldn't break the overall command, but it does mean that clicking it won't do anything. Make sure you've filled out the required boxes in your generator with something that will clearly display a result.

I would double check that the generator and minecraft version your are using are the same, as the recently released 1.12 contains some changes to key and value parsing

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.