1

“Rome: Total War” does not start. Every time I try to start it, I always get the 0xc000007b error message.

I have tried several solutions, but none of them has worked so far. I have tried these solutions and I have also tried the aio runtime package, but nothing has worked so far. I have restarted my computer and installed the game several times. But it still does not work.

My machine runs a Windows 7 64 bit version.

  • Where'd you get the game? Was it Steam? – Frank Dec 6 '17 at 12:52
  • No, it is an older version on CD. – Nemgathos Dec 6 '17 at 12:54
  • What's your hardware? Are your drivers up to date? The error can as well be caused by wrong graphic drivers or unsupported hardware (like on-board GPUs). – dly Dec 6 '17 at 14:09
  • I don’t know every hardware component. I would have to look them up. But updating the driver for my graphics card might help. I will give it a try. – Nemgathos Dec 6 '17 at 17:32
  • have you tried running in compatibility mode using a different version of windows? – Bayrattack Dec 8 '17 at 18:32
-1

There is an elaborate reddit post that offers a variaty of solutions. They are as followed :

here may be multiple reasons as to why you might receive 0xc00007b error when trying to run an application on a windows machine. 0xc000007b error usually comes from mixing up 32bit environment with 64bit one. For example 32bit application loads a 64bit dll causing 0xc000007b error.

Solution 1 In most cases it's .NET framework causing issues. This can easily fixed by re-installing latest .NET framework from [link]

Solution 2 Re-install the application that you are trying to run. It sounds simple but the application data files could be corrupt or missing. This could be caused by a installation that did not complete successfully or by a virus.

Solution 3 Running the application as an administrator could fix this error. Right click on the program shortcut or program .exe file, then click on Properties, and on the Compatibility tab. Check the Run this program as an administrator box, and click on OK

Solution 4 Restart your computer as some applications require restart after installation to function properly.

Solution 5 Run Windows update as it can provide application fixes and updates. Furthermore it installs missing drivers and updates the outdated ones like graphic card drivers. Windows 7 / 8 / 8.1 users need to search for "windows update". select all important and optional updates and click on the "install updates" button. If you use Windows XP navigate navigate to Windows Update by choosing Start > All Programs > Windows Update. When the scan is complete,Click the Review and Install Updates link. Finally press the "install now" button.

Solution 6 manually update the application if possible.

Solution 7 re-install Microsoft Visual C++ runtime from [x32 link] or [x64 link]

Solution 8 re-install DirectX [link]

Solution 9 Many times hard disk problems can be repaired using the chkdsk command. If you are using windows 7 press the start button in bottom left corner of your screen. If you are using windows 8 / 8.1 press the windows key .Search for "cmd" and Right click it and select "Run as administrator". Windows XP users Click on start > run. In the Run box, type in "cmd" in the box. A CMD window should appear. In that window you can just type it as you see "chkdsk c: /f /r". If you have more then one drive or partition, you will need to tell it the disk (chkdsk d: /f /r). If it is the primary windows disk c: it will ask you to schedule it for next boot. When you restart, it will do a chkdsk for you before even getting to the login screen.

Solution 10 This solution only works for a 64-bit system. It requires replacing files is system32 directory so be careful. Only attempt this solution if you are confident and if other solutions have failed. When Microsoft Visual C++ Redistributable Package is not properly configured it may cause 0xc00007b error. Firstly download the zip file [link] and decompress it. Reboot in safe mode and go to C:\Windows\System32. copy all files included in the zip package (mfc100.dll, mfc100u.dll, msvcr100.dll, msvcp100.dll and msvcr100_clr0400.dll) to C:\Windows\System32 replacing the current ones. After that reboot in normal mode.

If all the solutions above haven't worked i would consider backing up data and performing a clean install of windows

  • I have already linked this post in my question. Nothing has helped so far. – Nemgathos Dec 6 '17 at 13:39
  • Sorry I read over that, Have you tried a clean install – KevinTheGreat Dec 6 '17 at 13:47
  • I have tried to install the game several times. But that did not help. – Nemgathos Dec 6 '17 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.