2

Each time I start GTA IV in Steam I just get a black screen.

My graphics card is a GTX 1070 with 3 GB RAM, and I have found this thread, which mentions the solution to set the following parameters to the game shortcut in Steam:

-nomemrestrict -norestrictions

but this doesn't do anything.

Any other suggestions?

  • 1
    GTA 4 uses Games for Windows Live. It's a piece of garbage. That's probably what's giving you the black screen. – Nelson Jun 17 '18 at 10:09
  • yeah well right now I have bought a game that does not work :-( – u123 Jun 17 '18 at 10:14
  • It happens. If you bought it recently get a refund. It's a giant pain in the butt to run the game on modern OS. – Nelson Jun 17 '18 at 10:19
  • I have gotten this working on my windows 10 machine using launch options and a patch file which ignores some WLive features. I'll make an answer when i get the oppertunery @u123 – L_Church Jun 25 '18 at 13:16
1

I have this working on my Windows 10 PC. In order to actually play it, I had to download a file called xlive.dll and place that into my GTA IV folder in the '/steamapps' folder for Steam. Searching something along the lines of "GTA IV xlive" might get you that file.

I set some launch options for the game which make it run how I want it too.

-nomemrestrict -norestrictions-framelimit 0-noprecache-novblank -availablevidmem 2048.0 -windowed

You can try these - the last number can be edited to suit your needs (if you have more or less video memory available).

I'm not sure if the spacing matters. You can try appending spaces into there but I don't think it makes a difference.
Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.