I placed a house in my Minecraft world. This house was created by another user. Upon editing this house, I encountered an invisible force field. I destroyed an item and then tried to place something in its place but was unable to place an item in that space.

I'll try to explain this better: I destroyed a block so now there is empty space where that block once was. I then tried to place a different block in this space but I am unable to do so. It's as if there is an invisible force field around certain blocks in this house.

How do you remove this force field to make the game work again?

  • Do you still have that problem after exiting and re-entering the world? Aug 12, 2019 at 17:36

1 Answer 1


These are colloquially known as phantom blocks, ghost blocks, or just simply invisible blocks.

They have nothing with phantoms to do and they've occurred for far longer.

The solution is usually:

  1. Disconnect from the server / exit the single player world.
  2. Connect back to the server / join the single player world again.

If that doesn't work you might try:

  • Restarting Minecraft
  • Restarting the server

If that still doesn't work then you're going to have to wait for a fix, in writing time it seems ghost blocks have made a return to 1.14.4: https://bugs.mojang.com/browse/MC-156852 (this is currently flagged open and confirmed).

If your server runs on Paper there's a fix out for that, but otherwise you will have to wait.

  • 1
    Additional solution to the most persistent ghost blocks - use pistons; if extending the piston into the ghost block doesn't remove it, you can still try to move it somewhere where it won't be a problem. Or where it will be a problem to someone else.
    – SF.
    Aug 13, 2019 at 7:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .