1

I know I'm late to the party, both because this game is old and because similar questions have been asked. But none of the other answers I've seen work for me so far.

My Problem

In Skyrim, I can go to Settings -> Controls, and change the button mapping for my controller (controller, not keyboard). From then on, everything works perfectly until I quit the game. Upon reopening Skyrim later for another session, I find that the controls have reset to what they were previously. This happens every time I close and reopen the game, forcing me to remap my desired controls at the start of every game session.

My Setup

I'm running Skyrim Special Edition on a Windows 10 PC with Steam. I have all three official DLC packs installed. I have one mod installed (through the official, in-game mod system), but it's only the "Unofficial Skyrim Patch", which to my understanding is a highly used, very benign mod. I'm using a Dualshock 4 controller (PS4 controller), connected via USB.

Interesting Note

If I play without a controller and change a keyboard mapping, that change does persist through sessions. So it's only the controller mapping that seems to be the problem, not the keyboard mapping.

What I've Tried

These are suggestions from various other posts which I've tried to no success.

Running as Administrator

I've gone into the compatibility settings for both SkyrimSE.exe and SkyrimSELauncher.exe and checked off "Run this program as an Administrator". No change.

Taking ownership of the install folder

I looked at the security settings of C:\Program Files (x86)\Steam\steamapps\common\Skyrim Special Edition and I can see that my current user is already the owner of this folder. So this suggestion as not applicable.

Delete ControlMap_Custom.txt

When I launch Skyrim with this file deleted, the controls that I get are different from the usual controls, but are not the ones I saved. After remapping the controls in Skyrim, this file is recreated, and then next time I open the game, I'm back to the original incorrect controls.

Contrary to the .txt file extension, this file does not seem to be a text file. Opening it in Notepad is gibberish, so I can't even take a look at what's inside. I will say that upon testing, changing my controller mapping doesn't seem to affect at all what gibberish is inside the file. It stays consistent no matter what buttons I assign to what function.

What I Want

What I'd really like is a fix for this very simple problem. Ideally there would be a way to make this work in vanilla Skyrim itself, but at this point I'll accept a mod solution as well.

Short of that, I'd appreciate any information on where/how Skyrim stores its controller mapping. And if the answer is the ControlMap_Custom.txt file, I'd appreciate info on how to open that file correctly so I can read (or hopefully even edit) it.

2
  • Assuming this is a steam release, have you tried setting the controller up in Steam/Big Picture? – Kaizerwolf Jan 19 at 13:39
  • 1
    @Kaizerwolf Yes that works! I didn't realize Steam could override the controller input to swap the buttons around. Please post this as a proper answer so I can accept it. – Keith Stein Jan 20 at 0:31
0

The solution would appear to be to set up your controller configs in Steam/Big Picture Mode. Open Steam, select Steam from the top right menu, select Settings, then navigate to the Controller submenu. From here, click either General Controller Settings or Big Picture Configuration, which should both accomplish the same thing.

0

I finally stumbled upon the completely vanilla solution by accident!

I was going through with @Kaizerwolf's solution, using Steam to re-map my controller to fit the controls Skyrim was insisting on, but then I noticed something: the control option for "Shout" was completely missing from the game. It wasn't showing up in the Skyrim controls menu at all.

I think this had happened a couple times before, and I'd fixed it by unplugging and re-plugging my controller while the game was open (which switched the game from controller to keyboard/mouse mode and back)- that seem to fix it temporarily at least. But this time I decided to Google that problem instead. I read someone had fixed that problem (getting the "Shout" option to reappear) by using the in-game option to reset the controls to default.

This is something I'd never tried before, and a feature I hadn't noticed or thought of. But sure enough, in Skyrim's in-game controls menu, there's an option labeled "Default".

I reset to default, and decided to try changing the in-game controls one last time after that. And it worked! I closed and opened the game- even restarted my computer- and the controls didn't reset!

TL;DR

I fixed this by opening the in-game Controls menu (System -> Controls) and pressing the "Default" button. This reset the controls to default, and afterwards changes I made to those controls persisted and did not reset between sessions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.