I've got a stone that is blocking construction of a workshop. It's not forbidden or marked to be dumped, there are no suspended builds that might be using it, but my dwarves are apparently refusing to move it and construct the workshop. I've tried marking it to be dumped in a garbage zone, and that didn't get it moved either. Is the stone glued to the ground or something?

alt text

  • 2
    I love the question title. I actually imagine Dwarves being quite irate at not being able to move a rock; even taking it as a personal challenge. Aug 19, 2010 at 23:51
  • 3
    Pics or it didn't happen!
    – tzenes
    Aug 19, 2010 at 23:53
  • 3
    I've seen that once before but never did figure out what was going on. Maybe you can dispose of it by channeling on its square and then building a floor? (I don't recall off the top of my head if that blocks construction; I /think/ not, but I could be wrong.
    – Scott
    Aug 20, 2010 at 0:00
  • 6
    could we get some freehand circles to show us which parts of the pics are of interest? Aug 20, 2010 at 0:23
  • 3
    Heh. Every comment on this question is upvoted at least once. Aug 20, 2010 at 8:28

3 Answers 3


Marking the stone to be dumped(k-d) should get rid of it, even it's not immediate.

You can also try to build a (C)floor at that square using that material, as that will usually just use that stone.

You can also designate to channel the tile the stone is sitting on then build a (C)floor over the hole.

If you actually mean a natural boulder above ground, then designate it to be smoothed.

EDIT: Nice pic. ;)

  • 1
    I tried building a wall on top of the stone in question, and it wouldn't let me use that stone, but rather 1 tile away. Aug 20, 2010 at 0:08
  • 5
    I channeled the tile the stone was on, built a floor over the hole, then was able to construct the workshop. Aug 20, 2010 at 1:33
  • 1
    Too bad you can't mark comments as accepted, eh? =p Aug 20, 2010 at 2:40
  • 1
    Perhaps Scott could add it as an answer
    – Torpesh
    Aug 20, 2010 at 16:44
  • 1
    gah, you beat me to cleaning up my edit. Aug 20, 2010 at 19:33

I think I've had this happen a couple of times. It's like the dwarves get confused about what they can or can't move when constructing the workshop. I've fixed it by cancelling the workshop and then rebuilding it. That seems to clear the drunken fog from their brains and allow the workshop construction to proceed.


What this generally means is that you've queued the material in question for a construction or building, but the dwarves haven't gotten around to it yet. The only one "allowed" to move the item is the builder who's going to use it to build the whatever.

In this case, forbidding / marking the stone for dumping is actually preventing anything being done about it, because the stone is limited to the building until it is finished - and as long as the stone is marked for dumping, it will never be started. This awkward chain can only be broken by canceling the original construction that requires the stone.

The giveaway in this case is that trying to build in the same square as the recalcitrant stone causes it to not appear as an available option.

Channeling the square the stone is in is likely to result in a "construction canceled, item misplaced" message, but will solve the problem if you can't figure out which building wanted the stone in question.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .